summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-05-28 14:56:32 +0000
committerSamuli Suominen <drac@gentoo.org>2007-05-28 14:56:32 +0000
commitc16ba5eaa735af7294d947d89d2f18f91870f0d6 (patch)
treef8c509ebc6a75f147d761631bfa9f6a62170b929 /x11-misc/bubblemon/bubblemon-1.46-r1.ebuild
parentreally stable it and RESTRICT=test (diff)
downloadgentoo-2-c16ba5eaa735af7294d947d89d2f18f91870f0d6.tar.gz
gentoo-2-c16ba5eaa735af7294d947d89d2f18f91870f0d6.tar.bz2
gentoo-2-c16ba5eaa735af7294d947d89d2f18f91870f0d6.zip
Thanks to 6thpink and Bernard Cafarelli for porting bubblemon to GTK+-2.0 in bug 175730.
(Portage version: 2.1.2.7)
Diffstat (limited to 'x11-misc/bubblemon/bubblemon-1.46-r1.ebuild')
-rw-r--r--x11-misc/bubblemon/bubblemon-1.46-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/bubblemon/bubblemon-1.46-r1.ebuild b/x11-misc/bubblemon/bubblemon-1.46-r1.ebuild
new file mode 100644
index 000000000000..b745a5dca26e
--- /dev/null
+++ b/x11-misc/bubblemon/bubblemon-1.46-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bubblemon/bubblemon-1.46-r1.ebuild,v 1.1 2007/05/28 14:56:32 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="A fun monitoring applet for your desktop, complete with swimming duck"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${PN}-dockapp-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}-dockapp-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gtk.patch
+}
+
+src_compile() {
+ emake GENTOO_CFLAGS="${CFLAGS}" || die "emake failed."
+}
+
+src_install () {
+ dobin bubblemon
+
+ dodoc ChangeLog README doc/Xdefaults.sample
+
+ insinto /usr/share/${PN}
+ doins misc/{*.xcf,*.wav}
+
+ exeinto /usr/share/${PN}
+ doexe misc/wakwak.sh
+}