summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-04-20 01:30:24 +0000
committerMark Wright <gienah@gentoo.org>2013-04-20 01:30:24 +0000
commit6507fef4803e96a9feaf5ce4f97a0f871772ae7b (patch)
tree4d21d63ca501bb9b7634b483fe1319a26d3d9f04 /x11-misc/cdm
parentFix immediate segfault (updated libassuan2 patch from Fedora 15, thanks Kevin... (diff)
downloadgentoo-2-6507fef4803e96a9feaf5ce4f97a0f871772ae7b.tar.gz
gentoo-2-6507fef4803e96a9feaf5ce4f97a0f871772ae7b.tar.bz2
gentoo-2-6507fef4803e96a9feaf5ce4f97a0f871772ae7b.zip
Bump cdm to snapshot of https://github.com/ghost1227/cdm
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'x11-misc/cdm')
-rw-r--r--x11-misc/cdm/ChangeLog10
-rw-r--r--x11-misc/cdm/cdm-0.6.1_pre20130419.ebuild71
2 files changed, 78 insertions, 3 deletions
diff --git a/x11-misc/cdm/ChangeLog b/x11-misc/cdm/ChangeLog
index 86bbb1822f46..05bfeedbd1e9 100644
--- a/x11-misc/cdm/ChangeLog
+++ b/x11-misc/cdm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/cdm
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/cdm/ChangeLog,v 1.2 2012/05/05 11:45:41 gienah Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/cdm/ChangeLog,v 1.3 2013/04/20 01:30:24 gienah Exp $
+
+*cdm-0.6.1_pre20130419 (20 Apr 2013)
+
+ 20 Apr 2013; Mark Wright <gienah@gentoo.org> +cdm-0.6.1_pre20130419.ebuild:
+ Bump cdm to snapshot of https://github.com/ghost1227/cdm
05 May 2012; Mark Wright <gienah@gentoo.org> cdm-0.5.3.ebuild, metadata.xml:
Add consolekit and pam use flags.
@@ -11,4 +16,3 @@
+files/cdm-0.5.3-invalid-MIT-cookie.patch, +metadata.xml:
Thanks to keenblade and Alec M. for creating and patching the ebuild. Fixes
bug 309257.
-
diff --git a/x11-misc/cdm/cdm-0.6.1_pre20130419.ebuild b/x11-misc/cdm/cdm-0.6.1_pre20130419.ebuild
new file mode 100644
index 000000000000..113d15459d05
--- /dev/null
+++ b/x11-misc/cdm/cdm-0.6.1_pre20130419.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/cdm/cdm-0.6.1_pre20130419.ebuild,v 1.1 2013/04/20 01:30:24 gienah Exp $
+
+EAPI="4"
+
+inherit pam eutils
+
+DESCRIPTION="The Console Display Manager"
+HOMEPAGE="https://wiki.archlinux.org/index.php/CDM"
+SRC_URI="http://dev.gentoo.org/~gienah/snapshots/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pam consolekit"
+REQUIRED_USE="consolekit? ( pam )"
+
+DEPEND="app-shells/bash"
+
+RDEPEND="${DEPEND}
+ dev-util/dialog
+ x11-apps/xdpyinfo
+ x11-apps/xinit
+ consolekit? ( sys-auth/consolekit
+ sys-apps/dbus )
+ pam? ( virtual/pam )"
+
+src_prepare() {
+ if ! use consolekit; then
+ sed -e 's@consolekit=yes@consolekit=no@' \
+ -i "${S}/src/cdmrc" || die "Could not turn off consolekit in cdmrc"
+ fi
+}
+
+src_install() {
+ if use pam ; then
+ pamd_mimic system-local-login cdm auth account session
+ fi
+
+ insinto /usr/bin/
+ insopts -m0755
+ dobin src/${PN} src/${PN}-xlaunch
+
+ insinto /etc
+ insopts -Dm644
+ doins src/cdmrc
+
+ insinto /etc/profile.d/
+ insopts -Dm755
+ newins src/profile.sh zzz-${PN}.sh
+
+ # Install themes
+ insinto /usr/share/${PN}/themes
+ doins themes/*
+ # Copy documentation manually
+ dodoc ChangeLog-0.6 ChangeLog-before-0.6 README.md
+}
+
+pkg_postinst() {
+ ewarn "In order to use CDM you must first edit your /etc/cdmrc"
+ ewarn "At least the binlist, namelist and flaglist entries should be added or edited"
+ ewarn "to specify the X window managers and console shells that you want before"
+ ewarn "you start CDM. Something like:"
+ ewarn "binlist=('xmonad' 'startkde' '/bin/zsh --login' '/bin/bash --login')"
+ ewarn "namelist=('XMonad' 'KDE' 'Console Zsh' 'Console Bash')"
+ ewarn "flaglist=(X X C C)"
+ ewarn "Ensure the flaglist X entries correspond to the X-Windows programs, and the"
+ ewarn "C entries correspond to console shells. Then just login with your username."
+ ewarn "Remove xdm from default runlevel."
+}