summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-15 23:50:37 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-15 23:50:37 +0000
commitdede2b480453a9a931e2b3995884dee05cce33f9 (patch)
tree7d8ed34ad8f6daa3a124d537686a23227bcc634e /x11-misc/compton
parentBeta channel bump. (diff)
downloadgentoo-2-dede2b480453a9a931e2b3995884dee05cce33f9.tar.gz
gentoo-2-dede2b480453a9a931e2b3995884dee05cce33f9.tar.bz2
gentoo-2-dede2b480453a9a931e2b3995884dee05cce33f9.zip
Initial commit with ebuild created by Julian Ospald.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/compton')
-rw-r--r--x11-misc/compton/ChangeLog10
-rw-r--r--x11-misc/compton/Manifest4
-rw-r--r--x11-misc/compton/compton-0_pre20120316.ebuild57
-rw-r--r--x11-misc/compton/metadata.xml11
4 files changed, 82 insertions, 0 deletions
diff --git a/x11-misc/compton/ChangeLog b/x11-misc/compton/ChangeLog
new file mode 100644
index 000000000000..ba05a056b9d3
--- /dev/null
+++ b/x11-misc/compton/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/compton
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/ChangeLog,v 1.1 2012/03/15 23:50:37 ssuominen Exp $
+
+*compton-0_pre20120316 (15 Mar 2012)
+
+ 15 Mar 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +compton-0_pre20120316.ebuild:
+ Initial commit with ebuild created by Julian Ospald.
+
diff --git a/x11-misc/compton/Manifest b/x11-misc/compton/Manifest
new file mode 100644
index 000000000000..91ca11f479e6
--- /dev/null
+++ b/x11-misc/compton/Manifest
@@ -0,0 +1,4 @@
+DIST compton-0_pre20120316.tar.xz 17572 RMD160 c4fd6779e632f70f1820e062ca6069cf8ee88324 SHA1 377995fa0c72e32721928522d932aa079e303a2c SHA256 5f6f152de9af3178cf814d0e73c24f3a6ddf97f35f9cf3e8fdb166d3c735ad80
+EBUILD compton-0_pre20120316.ebuild 1196 RMD160 91933c6312950e26995ea4813c4a5a88f35cd3a5 SHA1 940aa6d3ea45d0d157c69a01d9ed9cc6d1b1ac4f SHA256 e7c00c754a69095aa4e7ce1a813f802ba0e204d2e8a510d11c347a8d25c93210
+MISC ChangeLog 298 RMD160 cb9ba192b32664b53360a87d97f0dab8e7bac460 SHA1 3fe1944a86efab84665e1bfe69203cac30546597 SHA256 b9e72a156f956ef10c5cb3ad956c24b6aa056a4e8c5903f6ce0d63be29e80172
+MISC metadata.xml 362 RMD160 ebd59a0cd1550c3ed63aea1097c4cd1febe1b355 SHA1 74270cffb6d24235867426f27a43c5894764fddf SHA256 ccd7369195d103400eaf689d4f3b2c03e697d0f5ef0ca6eb26da1427f579a2e6
diff --git a/x11-misc/compton/compton-0_pre20120316.ebuild b/x11-misc/compton/compton-0_pre20120316.ebuild
new file mode 100644
index 000000000000..aa541f648550
--- /dev/null
+++ b/x11-misc/compton/compton-0_pre20120316.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/compton-0_pre20120316.ebuild,v 1.1 2012/03/15 23:50:37 ssuominen Exp $
+
+EAPI=4
+
+unset _live_inherits
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/chjj/compton.git"
+ _live_inherits="git-2"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+fi
+
+inherit toolchain-funcs ${_live_inherits}
+
+DESCRIPTION="A compositor for X, and a fork of xcompmgr-dana"
+HOMEPAGE="http://github.com/chjj/compton"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+COMMON_DEPEND="x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ x11-libs/libXrender"
+RDEPEND="${COMMON_DEPEND}
+ app-shells/bash
+ x11-apps/xprop
+ x11-apps/xwininfo"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ x11-proto/xproto"
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS/s/=/+=/' \
+ -e '/$(LIBS)$/s/$(CC)/$(CC) $(LDFLAGS)/' \
+ -e 's/`pkg-config --libs $(PACKAGES)`/$(shell pkg-config --libs $(PACKAGES))/' \
+ -e 's/`pkg-config --cflags $(PACKAGES)`/$(shell pkg-config --cflags $(PACKAGES))/' \
+ Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin ${PN} bin/settrans
+ doman man/${PN}.1
+ dodoc README.md
+}
diff --git a/x11-misc/compton/metadata.xml b/x11-misc/compton/metadata.xml
new file mode 100644
index 000000000000..56fcb65bf5fe
--- /dev/null
+++ b/x11-misc/compton/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>julian.ospald@googlemail.com</email>
+ <name>Julian Ospald</name>
+ <description>hasufell at Freenode</description>
+ </maintainer>
+</pkgmetadata>