summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-05-21 13:51:01 +0000
committerJeroen Roovers <jer@gentoo.org>2014-05-21 13:51:01 +0000
commit2e82093c0400138deb87e0eb304ed2c97942024c (patch)
tree6b92e0aa68183c6fab37135c6ea59bcb270085ff /x11-misc/devilspie2
parentVersion bump. (diff)
downloadgentoo-2-2e82093c0400138deb87e0eb304ed2c97942024c.tar.gz
gentoo-2-2e82093c0400138deb87e0eb304ed2c97942024c.tar.bz2
gentoo-2-2e82093c0400138deb87e0eb304ed2c97942024c.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc/devilspie2')
-rw-r--r--x11-misc/devilspie2/ChangeLog7
-rw-r--r--x11-misc/devilspie2/devilspie2-0.36.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-misc/devilspie2/ChangeLog b/x11-misc/devilspie2/ChangeLog
index b747e5b3e10d..72e5751b180d 100644
--- a/x11-misc/devilspie2/ChangeLog
+++ b/x11-misc/devilspie2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/devilspie2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/devilspie2/ChangeLog,v 1.15 2014/04/22 12:41:09 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/devilspie2/ChangeLog,v 1.16 2014/05/21 13:51:01 jer Exp $
+
+*devilspie2-0.36 (21 May 2014)
+
+ 21 May 2014; Jeroen Roovers <jer@gentoo.org> +devilspie2-0.36.ebuild:
+ Version bump.
*devilspie2-0.33 (22 Apr 2014)
diff --git a/x11-misc/devilspie2/devilspie2-0.36.ebuild b/x11-misc/devilspie2/devilspie2-0.36.ebuild
new file mode 100644
index 000000000000..2c18a1672cc9
--- /dev/null
+++ b/x11-misc/devilspie2/devilspie2-0.36.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/devilspie2/devilspie2-0.36.ebuild,v 1.1 2014/05/21 13:51:01 jer Exp $
+
+EAPI=5
+
+# check locales on version bump!
+PLOCALES="fi fr ja nl pt_BR ru sv"
+inherit flag-o-matic toolchain-funcs l10n
+
+DESCRIPTION="Devilspie like window matching utility, using LUA for scripting"
+HOMEPAGE="http://devilspie2.gusnan.se"
+SRC_URI="http://devilspie2.gusnan.se/download/${PN}_${PV}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.32.4:2
+ >=dev-lang/lua-5.1.5
+ >=x11-libs/gtk+-3.4.4:3
+ >=x11-libs/libwnck-3.4.4:3
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+src_prepare() {
+ use debug && append-cflags -D_DEBUG
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) PREFIX="/usr" LANGUAGES="$(l10n_get_locales)"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" LANGUAGES="$(l10n_get_locales)" install
+
+ dodoc AUTHORS ChangeLog README README.translators TODO VERSION
+ doman devilspie2.1
+}
+
+pkg_postinst() {
+ elog "Default directory for scripts is ~/.config/devilspie2/"
+}