summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-03-01 20:55:15 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-03-01 20:55:15 +0000
commitdf259c9d53064ba0d9e6fdfbda743d4e20229b12 (patch)
treef5efd16cc9dca30fb9e53a314c030e0da8a4ffda /x11-misc/e-fancylauncher/e-fancylauncher-0.7-r1.ebuild
parentfixed download location of bbconf (diff)
downloadgentoo-2-df259c9d53064ba0d9e6fdfbda743d4e20229b12.tar.gz
gentoo-2-df259c9d53064ba0d9e6fdfbda743d4e20229b12.tar.bz2
gentoo-2-df259c9d53064ba0d9e6fdfbda743d4e20229b12.zip
fix installation
Diffstat (limited to 'x11-misc/e-fancylauncher/e-fancylauncher-0.7-r1.ebuild')
-rw-r--r--x11-misc/e-fancylauncher/e-fancylauncher-0.7-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/e-fancylauncher/e-fancylauncher-0.7-r1.ebuild b/x11-misc/e-fancylauncher/e-fancylauncher-0.7-r1.ebuild
new file mode 100644
index 000000000000..c062d3794f10
--- /dev/null
+++ b/x11-misc/e-fancylauncher/e-fancylauncher-0.7-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/e-fancylauncher/e-fancylauncher-0.7-r1.ebuild,v 1.1 2003/03/01 20:55:15 lostlogic Exp $
+
+S="${WORKDIR}/Epplets-${PV}"
+
+DESCRIPTION="E-FancyLauncher epplet"
+SRC_URI="http://www.docs.uu.se/~adavid/Epplets/E-FancyLauncher-${PV}.tgz"
+
+HOMEPAGE="http://www.docs.uu.se/~adavid/Epplets"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc"
+S=${WORKDIR}/E-FancyLauncher
+
+DEPEND="x11-misc/epplet-base"
+
+src_compile() {
+ make clean
+ emake
+}
+
+src_install () {
+ sed -e 's/mkdir/mkdir -p/' ${S}/makefile > tmp~
+ mv tmp~ makefile
+ dodir /usr/bin
+ dodir /usr/share/enlightenment/epplet_icons
+ EBIN=${D}/usr/bin \
+ EROOT=${D}/usr/share/enlightenment \
+ einstall ${EBIN} ${EROOT}
+ dodoc ChangeLog
+}