summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-06-04 17:37:08 +0000
committerJeroen Roovers <jer@gentoo.org>2014-06-04 17:37:08 +0000
commit821efa174c319a717d899d72e99260d5210cf083 (patch)
tree74e9b886b606ae63ded470f9c8a37723156b6e20 /x11-misc/easystroke
parentDropped myself from maintainership. (diff)
downloadgentoo-2-821efa174c319a717d899d72e99260d5210cf083.tar.gz
gentoo-2-821efa174c319a717d899d72e99260d5210cf083.tar.bz2
gentoo-2-821efa174c319a717d899d72e99260d5210cf083.zip
Add upstream patches for bug #512428 by Small Penguin.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc/easystroke')
-rw-r--r--x11-misc/easystroke/ChangeLog9
-rw-r--r--x11-misc/easystroke/easystroke-0.6.0-r1.ebuild61
-rw-r--r--x11-misc/easystroke/files/easystroke-0.6.0-buttons-scroll-send.patch43
-rw-r--r--x11-misc/easystroke/files/easystroke-0.6.0-reinstate-signal-handlers.patch42
4 files changed, 154 insertions, 1 deletions
diff --git a/x11-misc/easystroke/ChangeLog b/x11-misc/easystroke/ChangeLog
index 853e129a9a9d..5738a86515ed 100644
--- a/x11-misc/easystroke/ChangeLog
+++ b/x11-misc/easystroke/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/easystroke
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/easystroke/ChangeLog,v 1.1 2014/06/04 03:14:31 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/easystroke/ChangeLog,v 1.2 2014/06/04 17:37:08 jer Exp $
+
+*easystroke-0.6.0-r1 (04 Jun 2014)
+
+ 04 Jun 2014; Jeroen Roovers <jer@gentoo.org> +easystroke-0.6.0-r1.ebuild,
+ +files/easystroke-0.6.0-buttons-scroll-send.patch,
+ +files/easystroke-0.6.0-reinstate-signal-handlers.patch:
+ Add upstream patches for bug #512428 by Small Penguin.
*easystroke-0.6.0 (04 Jun 2014)
diff --git a/x11-misc/easystroke/easystroke-0.6.0-r1.ebuild b/x11-misc/easystroke/easystroke-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..f8d2578a5168
--- /dev/null
+++ b/x11-misc/easystroke/easystroke-0.6.0-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/easystroke/easystroke-0.6.0-r1.ebuild,v 1.1 2014/06/04 17:37:08 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="a gesture-recognition application for X11"
+HOMEPAGE="http://sourceforge.net/apps/trac/easystroke/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-libs/boost
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cellrendertextish.patch
+ epatch "${FILESDIR}"/${P}-desktop.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-reinstate-signal-handlers.patch
+ epatch "${FILESDIR}"/${P}-buttons-scroll-send.patch
+
+ tc-export CC CXX PKG_CONFIG
+
+ strip-linguas -i po/
+
+ local es_lingua lang
+ for es_lingua in $( printf "%s\n" po/*.po ); do
+ lang=${es_lingua/po\/}
+ has ${lang/.po/} ${LINGUAS} || rm ${es_lingua}
+ done
+}
+
+src_compile() {
+ emake \
+ AOFLAGS='' \
+ LDFLAGS="${LDFLAGS}" \
+ PREFIX=/usr
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+}
diff --git a/x11-misc/easystroke/files/easystroke-0.6.0-buttons-scroll-send.patch b/x11-misc/easystroke/files/easystroke-0.6.0-buttons-scroll-send.patch
new file mode 100644
index 000000000000..27bfa4cfee66
--- /dev/null
+++ b/x11-misc/easystroke/files/easystroke-0.6.0-buttons-scroll-send.patch
@@ -0,0 +1,43 @@
+From 5388934e722308cd314d65e362ddfaf6e5ab6c94 Mon Sep 17 00:00:00 2001
+From: Thomas Jaeger <ThJaeger@gmail.com>
+Date: Sat, 13 Apr 2013 14:10:35 -0400
+Subject: Make buttons and scroll work properly with 'send'
+
+---
+ handler.cc | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/handler.cc b/handler.cc
+index f47aae3..c1bd279 100644
+--- a/handler.cc
++++ b/handler.cc
+@@ -545,7 +545,7 @@ class AbstractScrollHandler : public Handler {
+
+ protected:
+ AbstractScrollHandler() : last_t(0), offset_x(0.0), offset_y(0.0) {
+- if (!prefs.move_back.get() || xstate->current_dev->absolute)
++ if (!prefs.move_back.get() || (xstate->current_dev && xstate->current_dev->absolute))
+ return;
+ Window dummy1, dummy2;
+ int dummy3, dummy4;
+@@ -563,7 +563,7 @@ protected:
+ }
+ protected:
+ void move_back() {
+- if (!prefs.move_back.get() || xstate->current_dev->absolute)
++ if (!prefs.move_back.get() || (xstate->current_dev && xstate->current_dev->absolute))
+ return;
+ XTestFakeMotionEvent(dpy, DefaultScreen(dpy), orig_x, orig_y, 0);
+ }
+@@ -1115,6 +1115,8 @@ XState::XState() : current_dev(NULL), in_proximity(false), accepted(true) {
+
+ void XState::run_action(RAction act) {
+ RModifiers mods = act->prepare();
++ IF_BUTTON(act, b)
++ return handler->replace_child(new ButtonHandler(mods, b));
+ if (IS_IGNORE(act))
+ return handler->replace_child(new IgnoreHandler(mods));
+ if (IS_SCROLL(act))
+--
+1.8.4
+
diff --git a/x11-misc/easystroke/files/easystroke-0.6.0-reinstate-signal-handlers.patch b/x11-misc/easystroke/files/easystroke-0.6.0-reinstate-signal-handlers.patch
new file mode 100644
index 000000000000..2e96346459a8
--- /dev/null
+++ b/x11-misc/easystroke/files/easystroke-0.6.0-reinstate-signal-handlers.patch
@@ -0,0 +1,42 @@
+From 7bda4bd9c705413598ee9b534884bc7f23704932 Mon Sep 17 00:00:00 2001
+From: Thomas Jaeger <ThJaeger@gmail.com>
+Date: Thu, 20 Jun 2013 01:45:20 -0400
+Subject: Reinstate signal handlers that got lost in the gtk3 transition
+
+Also, fix a segfault when handling SIGINT.
+---
+ main.cc | 11 ++++++++++-
+ 1 file changed, 10 insertions(+), 1 deletion(-)
+
+diff --git a/main.cc b/main.cc
+index 55d0b3c..8cd9c56 100644
+--- a/main.cc
++++ b/main.cc
+@@ -161,7 +161,12 @@ void quit() {
+ xstate->bail_out();
+ dead = true;
+ win->hide();
+- xstate->queue(sigc::ptr_fun(&Gtk::Main::quit));
++ Glib::RefPtr<Gio::Application> app = Gio::Application::get_default();
++ xstate->queue(sigc::mem_fun(*app.operator->(), &Gio::Application::quit));
++}
++
++void sig_int(int) {
++ quit();
+ }
+
+ class App : public Gtk::Application, Base {
+@@ -371,6 +376,10 @@ void App::on_activate() {
+
+ create_config_dir();
+ unsetenv("DESKTOP_AUTOSTART_ID");
++
++ signal(SIGINT, &sig_int);
++ signal(SIGCHLD, SIG_IGN);
++
+ dpy = XOpenDisplay(NULL);
+ if (!dpy) {
+ printf(_("Couldn't open display.\n"));
+--
+1.8.4
+