summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-02-19 00:50:31 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-02-19 00:50:31 +0000
commit85e3abc51a422c08ed70702aa1f72d6200f00062 (patch)
tree661f09621f9296ec4eb22ca613f798dc5cf928a5 /x11-misc/fluxspace
parentInclude the lcdproc masks in sparc's selinux profiles, too (bug #148072) (diff)
downloadgentoo-2-85e3abc51a422c08ed70702aa1f72d6200f00062.tar.gz
gentoo-2-85e3abc51a422c08ed70702aa1f72d6200f00062.tar.bz2
gentoo-2-85e3abc51a422c08ed70702aa1f72d6200f00062.zip
Treecleaner fixes for bug #159504 and bug #135842.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'x11-misc/fluxspace')
-rw-r--r--x11-misc/fluxspace/ChangeLog7
-rw-r--r--x11-misc/fluxspace/files/digest-fluxspace-0.0.33
-rw-r--r--x11-misc/fluxspace/files/fluxspace-0.0.3-gcc41.patch21
-rw-r--r--x11-misc/fluxspace/fluxspace-0.0.3-r1.ebuild55
-rw-r--r--x11-misc/fluxspace/fluxspace-0.0.3.ebuild52
5 files changed, 55 insertions, 83 deletions
diff --git a/x11-misc/fluxspace/ChangeLog b/x11-misc/fluxspace/ChangeLog
index 203376ac37a3..d63567f99593 100644
--- a/x11-misc/fluxspace/ChangeLog
+++ b/x11-misc/fluxspace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/fluxspace
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fluxspace/ChangeLog,v 1.9 2007/02/09 06:19:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fluxspace/ChangeLog,v 1.10 2007/02/19 00:50:31 dirtyepic Exp $
+
+ 19 Feb 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +files/fluxspace-0.0.3-gcc41.patch, -fluxspace-0.0.3.ebuild,
+ fluxspace-0.0.3-r1.ebuild:
+ Treecleaner fixes for bug #159504 and bug #135842.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/x11-misc/fluxspace/files/digest-fluxspace-0.0.3 b/x11-misc/fluxspace/files/digest-fluxspace-0.0.3
deleted file mode 100644
index dedd974aa6b0..000000000000
--- a/x11-misc/fluxspace/files/digest-fluxspace-0.0.3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 70dd33a04aff85c25b5a7c30881cf026 fluxspace-0.0.3.tar.gz 2228750
-RMD160 3e8aabdbff63c112037d35b540f85ef045e786b2 fluxspace-0.0.3.tar.gz 2228750
-SHA256 37ccbb9b22736a2b7fd4e5c50216c513c6fbde2f108769e4796d2c53cedc8430 fluxspace-0.0.3.tar.gz 2228750
diff --git a/x11-misc/fluxspace/files/fluxspace-0.0.3-gcc41.patch b/x11-misc/fluxspace/files/fluxspace-0.0.3-gcc41.patch
new file mode 100644
index 000000000000..4bfcd2da5fa5
--- /dev/null
+++ b/x11-misc/fluxspace/files/fluxspace-0.0.3-gcc41.patch
@@ -0,0 +1,21 @@
+diff -Naur fluxspace-0.0.3-orig/src/PythonInterface.cc fluxspace-0.0.3/src/PythonInterface.cc
+--- fluxspace-0.0.3-orig/src/PythonInterface.cc 2002-11-22 00:24:42.000000000 -0600
++++ fluxspace-0.0.3/src/PythonInterface.cc 2007-02-18 18:22:35.000000000 -0600
+@@ -256,7 +256,7 @@
+ class PythonInterfaceModule
+ {
+ public:
+- PythonInterfaceModule::PythonInterfaceModule(const string& name_, PyObject* config_)
++ PythonInterfaceModule(const string& name_, PyObject* config_)
+ : name(name_),
+ next(NULL),
+ module(name_),
+@@ -266,7 +266,7 @@
+ FSInitialize = new MyPyFunctionPtr(module.dict.GetItemString("fluxlet_main"));
+ }
+
+- PythonInterfaceModule::~PythonInterfaceModule()
++ ~PythonInterfaceModule()
+ {
+ delete FSInitialize;
+ }
diff --git a/x11-misc/fluxspace/fluxspace-0.0.3-r1.ebuild b/x11-misc/fluxspace/fluxspace-0.0.3-r1.ebuild
index e8f3951854b7..f305465047b8 100644
--- a/x11-misc/fluxspace/fluxspace-0.0.3-r1.ebuild
+++ b/x11-misc/fluxspace/fluxspace-0.0.3-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fluxspace/fluxspace-0.0.3-r1.ebuild,v 1.8 2005/09/03 22:06:26 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fluxspace/fluxspace-0.0.3-r1.ebuild,v 1.9 2007/02/19 00:50:31 dirtyepic Exp $
+
+inherit eutils
IUSE=""
DESCRIPTION="Enhancements for workspace management within Fluxbox."
@@ -16,11 +18,15 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ppc ~sparc x86"
-myconf="--prefix=/usr"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+}
src_compile() {
- export LDFLAGS="-lstdc++"
- econf ${myconf} || die "Configure failed"
+ econf || die "Configure failed"
emake || die "Compile failed"
}
@@ -34,26 +40,21 @@ src_install () {
}
pkg_postinst() {
- # Fix typo in the config file
- sed -e "s/no\"\\\/no\"\//g" /usr/share/fluxspace/examples/fluxspace.xml > /tmp/fluxspace.xml
- cp -f /tmp/fluxspace.xml /usr/share/fluxspace/examples/fluxspace.xml
- rm -f /tmp/fluxspace.xml
-
- einfo " NOTES:"
- einfo
- einfo " 1. If you want to use the optional features for idesk and rox,"
- einfo " you must emerge them separately. (e.g., 'emerge idesk')"
- einfo
- einfo " 2. Copy /usr/share/fluxspace/examples/fluxspace.xml to"
- einfo " ~/.fluxbox and edit the file. Change the settings from"
- einfo " \"no\" to \"yes\" depending on what features you want enabled."
- einfo
- einfo " 3. Edit ~/.fluxbox/init to 'turn on' fluxspace. Change line:"
- einfo " session.screen0.rootCommand:"
- einfo " to..."
- einfo " session.screen0.rootCommand: fluxspace"
- einfo
- einfo " 4. Full documentation is available online at:"
- einfo " http://sourceforge.net/docman/display_doc.php?docid=16037&group_id=76737"
- einfo
+ elog " NOTES:"
+ elog
+ elog " 1. If you want to use the optional features for idesk and rox,"
+ elog " you must emerge them separately. (e.g., 'emerge idesk')"
+ elog
+ elog " 2. Copy /usr/share/fluxspace/examples/fluxspace.xml to"
+ elog " ~/.fluxbox and edit the file. Change the settings from"
+ elog " \"no\" to \"yes\" depending on what features you want enabled."
+ elog
+ elog " 3. Edit ~/.fluxbox/init to 'turn on' fluxspace. Change line:"
+ elog " session.screen0.rootCommand:"
+ elog " to..."
+ elog " session.screen0.rootCommand: fluxspace"
+ elog
+ elog " 4. Full documentation is available online at:"
+ elog " http://sourceforge.net/docman/display_doc.php?docid=16037&group_id=76737"
+ elog
}
diff --git a/x11-misc/fluxspace/fluxspace-0.0.3.ebuild b/x11-misc/fluxspace/fluxspace-0.0.3.ebuild
deleted file mode 100644
index 0d854b8ff439..000000000000
--- a/x11-misc/fluxspace/fluxspace-0.0.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fluxspace/fluxspace-0.0.3.ebuild,v 1.6 2005/07/09 16:30:55 swegener Exp $
-
-IUSE=""
-DESCRIPTION="Enhancements for workspace management within Fluxbox."
-SRC_URI="http://www.isomedia.com/homes/stevencooper/files/${P}.tar.gz"
-HOMEPAGE="http://www.isomedia.com/homes/stevencooper/"
-DEPEND="x11-wm/fluxbox
- x11-misc/idesk
- rox-base/rox
- media-libs/imlib2
- dev-lang/python
- dev-python/pyxml
- dev-lang/swig"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc"
-
-myconf="--prefix=/usr"
-
-src_compile() {
- export LDFLAGS="-lstdc++"
- econf ${myconf} || die
- emake || die
-}
-
-src_install () {
- einstall || die
- dosym /usr/lib/python2.2/site-packages/fluxspace.py /usr/lib/python2.2/site-packages/fluxspace/__init__.py
- dosym /usr/lib/libfluxspace.so /usr/lib/python2.2/site-packages/_fluxspace.so
- dodoc README COPYING AUTHORS ChangeLog NEWS README TODO
-}
-
-pkg_postinst() {
- # there is a typo in the xml file, so i'll fix it =)
-
- sed -e "s/no\"\\\/no\"\//g" /usr/share/fluxspace/examples/fluxspace.xml > /tmp/fluxspace.xml
- cp -f /tmp/fluxspace.xml /usr/share/fluxspace/examples/fluxspace.xml
- rm -f /tmp/fluxspace.xml
-
- einfo
- einfo " Copy /usr/share/fluxspace/examples/fluxspace.xml to your"
- einfo " ~/.fluxbox and edit it!"
- einfo " (just to make it work change all the \"no\" to \"yes\")"
- einfo
- einfo " In your ~/.fluxbox/init change:"
- einfo " session.screen0.rootCommand:"
- einfo " to:"
- einfo " session.screen0.rootCommand: fluxspace"
- einfo
-}