summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-08-15 11:25:39 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-08-15 11:25:39 +0000
commit18d797b954d917da20e39b70184e2720249a841e (patch)
treee064eeb4cb3d1038fab707127a97783ecd830526 /x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild
parentadded X and xosd use flag (diff)
downloadgentoo-2-18d797b954d917da20e39b70184e2720249a841e.tar.gz
gentoo-2-18d797b954d917da20e39b70184e2720249a841e.tar.bz2
gentoo-2-18d797b954d917da20e39b70184e2720249a841e.zip
added X and xosd use flag
Diffstat (limited to 'x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild')
-rw-r--r--x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild b/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild
new file mode 100644
index 000000000000..e33db07bc504
--- /dev/null
+++ b/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild,v 1.1 2003/08/15 11:25:28 lanius Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Make use of extra buttons on newer keyboards."
+SRC_URI="http://ypwong.org/hotkeys/${PV}/${PN}_${PV}.tar.gz"
+HOMEPAGE="http://ypwong.org/hotkeys/"
+IUSE="X gtk2 xosd"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="X? ( virtual/x11 )
+ >=dev-libs/libxml2-2.2.8
+ =sys-libs/db-3.2*
+ !>=sys-libs/db-4*
+ xosd? ( >=x11-libs/xosd-1.0.0 )
+ gtk2? ( >=x11-libs/gtk+-2.0.0 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+
+ use X \
+ && myconf="${myconf} --with-X" \
+ || myconf="${myconf} --without-X"
+
+ use xosd \
+ && myconf="${myconf} --with-xosd" \
+ || myconf="${myconf} --without-xosd"
+
+ use gtk2 \
+ && myconf="${myconf} --with-gtk" \
+ || myconf="${myconf} --without-gtk"
+
+ econf ${myconf} || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS ChangeLog COPYING README TODO
+}