summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-03-03 05:02:49 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-03-03 05:02:49 +0000
commit476ec099ab32422ec45cc0785aecda4cd3fab3fa (patch)
treecb0a537443cfb284683d4f6ac4e67182df8ab4ee /x11-misc/ipager
parentFix ChangeLog header (diff)
downloadgentoo-2-476ec099ab32422ec45cc0785aecda4cd3fab3fa.tar.gz
gentoo-2-476ec099ab32422ec45cc0785aecda4cd3fab3fa.tar.bz2
gentoo-2-476ec099ab32422ec45cc0785aecda4cd3fab3fa.zip
Fix build with GCC 4.7 (bug #423215).
(Portage version: 2.2.0_alpha164/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'x11-misc/ipager')
-rw-r--r--x11-misc/ipager/ChangeLog8
-rw-r--r--x11-misc/ipager/files/ipager-1.1.0-gcc47.patch12
-rw-r--r--x11-misc/ipager/ipager-1.1.0.ebuild7
3 files changed, 22 insertions, 5 deletions
diff --git a/x11-misc/ipager/ChangeLog b/x11-misc/ipager/ChangeLog
index 3d503ba4b5df..ddea057d622a 100644
--- a/x11-misc/ipager/ChangeLog
+++ b/x11-misc/ipager/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/ipager
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/ipager/ChangeLog,v 1.3 2010/02/06 20:14:38 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/ipager/ChangeLog,v 1.4 2013/03/03 05:02:49 dirtyepic Exp $
+
+ 03 Mar 2013; Ryan Hill <dirtyepic@gentoo.org> ipager-1.1.0.ebuild,
+ +files/ipager-1.1.0-gcc47.patch:
+ Fix build with GCC 4.7 (bug #423215).
06 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> ipager-1.1.0.ebuild:
Missing USE depend wrt #248571 by Kacper Kowalik.
diff --git a/x11-misc/ipager/files/ipager-1.1.0-gcc47.patch b/x11-misc/ipager/files/ipager-1.1.0-gcc47.patch
new file mode 100644
index 000000000000..f4c899302aeb
--- /dev/null
+++ b/x11-misc/ipager/files/ipager-1.1.0-gcc47.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/423215
+
+--- a/ipager.cpp
++++ b/ipager.cpp
+@@ -29,6 +29,7 @@
+ #include <config.h>
+ #endif
+
++#include <unistd.h>
+ #include <iostream>
+ #include <string>
+ using namespace std;
diff --git a/x11-misc/ipager/ipager-1.1.0.ebuild b/x11-misc/ipager/ipager-1.1.0.ebuild
index a7f4f2daf717..2aef97f58002 100644
--- a/x11-misc/ipager/ipager-1.1.0.ebuild
+++ b/x11-misc/ipager/ipager-1.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/ipager/ipager-1.1.0.ebuild,v 1.4 2010/02/06 20:14:38 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/ipager/ipager-1.1.0.ebuild,v 1.5 2013/03/03 05:02:49 dirtyepic Exp $
EAPI=2
inherit eutils
@@ -22,8 +22,9 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-scons_imlib2.patch
- epatch "${FILESDIR}"/${P}-gcc43.patch
epatch "${FILESDIR}"/${P}-scons_flags.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-gcc47.patch
}
src_compile() {