summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-03-26 00:22:51 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-03-26 00:22:51 +0000
commit14f00be24bdfbcd3c9fc49ef5068cf1ea0483b6b (patch)
tree7974b1fe4a6f5a3822f5de64252797c9a7d79c53 /x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0_pre1.ebuild
parentInitial import. (diff)
downloadgentoo-2-14f00be24bdfbcd3c9fc49ef5068cf1ea0483b6b.tar.gz
gentoo-2-14f00be24bdfbcd3c9fc49ef5068cf1ea0483b6b.tar.bz2
gentoo-2-14f00be24bdfbcd3c9fc49ef5068cf1ea0483b6b.zip
version bump
(Portage version: 2.1_pre6-r6)
Diffstat (limited to 'x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0_pre1.ebuild')
-rw-r--r--x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0_pre1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0_pre1.ebuild b/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0_pre1.ebuild
new file mode 100644
index 000000000000..be5509c86015
--- /dev/null
+++ b/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0_pre1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0_pre1.ebuild,v 1.1 2006/03/26 00:22:50 genstef Exp $
+
+inherit multilib
+
+MY_P=${PN/-/_}-${PV/_/-}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Mute/unmute and other macros for LINEAK"
+HOMEPAGE="http://lineak.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lineak/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="=x11-misc/lineakd-${PV}*"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ sed -i 's:$(DESTDIR)${DESTDIR}:$(DESTDIR):' default_plugin/Makefile
+
+ make DESTDIR=${D} \
+ PLUGINDIR=/usr/$(get_libdir)/lineakd/plugins \
+ install || die "make install failed"
+ dodoc AUTHORS README
+}