summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leitch <port001@gentoo.org>2003-12-13 22:56:34 +0000
committerIan Leitch <port001@gentoo.org>2003-12-13 22:56:34 +0000
commit5a2fadc145260b5610a9a7f88d4c6e0b2b92a3a8 (patch)
tree9b04ea985e83f143b68e5764926cf5dc4ddc52e9 /x11-misc/lineakd/lineakd-0.7.2.ebuild
parentversion bump and 0.7 + 0.6.1 marked stable on x86 - #35737 (diff)
downloadgentoo-2-5a2fadc145260b5610a9a7f88d4c6e0b2b92a3a8.tar.gz
gentoo-2-5a2fadc145260b5610a9a7f88d4c6e0b2b92a3a8.tar.bz2
gentoo-2-5a2fadc145260b5610a9a7f88d4c6e0b2b92a3a8.zip
version bump and 0.7 + 0.6.1 marked stable on x86 - #35737
Diffstat (limited to 'x11-misc/lineakd/lineakd-0.7.2.ebuild')
-rw-r--r--x11-misc/lineakd/lineakd-0.7.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-misc/lineakd/lineakd-0.7.2.ebuild b/x11-misc/lineakd/lineakd-0.7.2.ebuild
new file mode 100644
index 000000000000..b3b022f7b968
--- /dev/null
+++ b/x11-misc/lineakd/lineakd-0.7.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineakd/lineakd-0.7.2.ebuild,v 1.1 2003/12/13 22:56:30 port001 Exp $
+
+IUSE="xosd"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Linux support for Easy Access and Internet Keyboards features X11 support"
+HOMEPAGE="http://lineak.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lineak/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="x11-base/xfree
+ xosd? ( x11-libs/xosd )"
+
+src_compile() {
+ econf `use_with xosd` --with-x || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} lineakddocdir=/usr/share/doc/${P} install || die
+ dodoc AUTHORS COPYING INSTALL README TODO
+}