summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Vasilevski <yvasilev@gentoo.org>2006-06-04 20:26:01 +0000
committerYuri Vasilevski <yvasilev@gentoo.org>2006-06-04 20:26:01 +0000
commit22c8302a956888070a34d4aeb1ad4b660bced073 (patch)
tree93bab4f2ed59cc0c9610db238181f751c3357d8f /x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild
parentAdded cairo local USE flag to x11-misc/matchbox-keyboard package. (diff)
downloadgentoo-2-22c8302a956888070a34d4aeb1ad4b660bced073.tar.gz
gentoo-2-22c8302a956888070a34d4aeb1ad4b660bced073.tar.bz2
gentoo-2-22c8302a956888070a34d4aeb1ad4b660bced073.zip
- Initial Import.
(Portage version: 2.1_rc3-r5)
Diffstat (limited to 'x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild')
-rw-r--r--x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild b/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild
new file mode 100644
index 000000000000..12a8e83df6ca
--- /dev/null
+++ b/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2006-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild,v 1.1 2006/06/04 20:26:01 yvasilev Exp $
+
+inherit versionator
+
+DESCRIPTION="Matchbox-keyboard is an on screen 'virtual' or 'software' keyboard."
+HOMEPAGE="http://projects.o-hand.com/matchbox/"
+SRC_URI="http://projects.o-hand.com/matchbox/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE="debug cairo"
+
+DEPEND="x11-libs/libfakekey
+ cairo? ( x11-libs/cairo )
+ !cairo? ( x11-libs/libXft )"
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable cairo) \
+ || die "Configuration failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Installation failed"
+
+ dodoc AUTHORS Changelog INSTALL NEWS README
+}