summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-28 02:14:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-28 02:14:54 +0000
commit5995d7d6fd2ca6c09e590deefc788eb457cba45b (patch)
tree33c95f173ce69ba555847f965941e6f4144b23ff /x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild
parentSome mysql plugins (such as 'mysql_') do use DBD-mysql the same way PostgreSQ... (diff)
downloadgentoo-2-5995d7d6fd2ca6c09e590deefc788eb457cba45b.tar.gz
gentoo-2-5995d7d6fd2ca6c09e590deefc788eb457cba45b.tar.bz2
gentoo-2-5995d7d6fd2ca6c09e590deefc788eb457cba45b.zip
Initial commit.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild')
-rw-r--r--x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild b/x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild
new file mode 100644
index 000000000000..a0355bfea421
--- /dev/null
+++ b/x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/qtnotifydaemon/qtnotifydaemon-1.0.14.ebuild,v 1.1 2012/01/28 02:14:54 ssuominen Exp $
+
+EAPI=4
+inherit qt4-r2
+
+DESCRIPTION="A flexible and configurable notification daemon"
+HOMEPAGE="http://drull.org.ru/qtnotifydaemon/ http://sourceforge.net/projects/qtnotifydaemon/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4
+ !x11-misc/notification-daemon
+ !x11-misc/notify-osd"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/share/dbus-1/services
+ doins org.freedesktop.Notifications.service
+
+ doman debian/${PN}.1
+}