summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-01-22 13:05:30 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-01-22 13:05:30 +0000
commite5328b4fe11a016b667f56a761f16022428ccd1d (patch)
treee4ad9fd470fd07ab6a3255865fe7361123d040a1 /x11-misc/screengrab
parentsparc stable, remove old and add patch to fix build with >=e2fsprogs-1.4.14 f... (diff)
downloadgentoo-2-e5328b4fe11a016b667f56a761f16022428ccd1d.tar.gz
gentoo-2-e5328b4fe11a016b667f56a761f16022428ccd1d.tar.bz2
gentoo-2-e5328b4fe11a016b667f56a761f16022428ccd1d.zip
Version bump
(Portage version: 2.2.0_alpha18/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/screengrab')
-rw-r--r--x11-misc/screengrab/ChangeLog7
-rw-r--r--x11-misc/screengrab/screengrab-0.9.1.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/x11-misc/screengrab/ChangeLog b/x11-misc/screengrab/ChangeLog
index 1a0d9b8c991d..c8918507cb55 100644
--- a/x11-misc/screengrab/ChangeLog
+++ b/x11-misc/screengrab/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/screengrab
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/screengrab/ChangeLog,v 1.10 2011/01/19 22:53:54 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/screengrab/ChangeLog,v 1.11 2011/01/22 13:05:30 hwoarang Exp $
+
+*screengrab-0.9.1 (22 Jan 2011)
+
+ 22 Jan 2011; Markos Chandras <hwoarang@gentoo.org> +screengrab-0.9.1.ebuild:
+ Version bump
*screengrab-0.9 (19 Jan 2011)
diff --git a/x11-misc/screengrab/screengrab-0.9.1.ebuild b/x11-misc/screengrab/screengrab-0.9.1.ebuild
new file mode 100644
index 000000000000..b2af4181fe12
--- /dev/null
+++ b/x11-misc/screengrab/screengrab-0.9.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/screengrab/screengrab-0.9.1.ebuild,v 1.1 2011/01/22 13:05:30 hwoarang Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="Qt tool for geting screenshots"
+HOMEPAGE="http://code.google.com/p/screengrab-qt/"
+SRC_URI="http://screengrab-qt.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # do not install license
+ sed -i "/LICENSE.txt/d" CMakeLists.txt \
+ || die "failed to patch cmakelists"
+ # install docs in the right dir
+ sed -i "s#DESTINATION share/doc/screengrab#DESTINATION share/doc/${PF}#" \
+ CMakeLists.txt || die "failed to patch doc dir"
+ sed -i "s:screengrab%1html:${PF}%1html:" src/ui/mainwindow.cpp || die
+}