summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-02-18 20:25:44 +0000
committerSamuli Suominen <drac@gentoo.org>2008-02-18 20:25:44 +0000
commitd2d06621232e986e14015d2636732588c687ed71 (patch)
tree681e093ef96f3e17d044d6de54fc539958d2d256 /x11-misc/suxpanel
parentrip out reintroduced ppc-macos conditional code (diff)
downloadgentoo-2-d2d06621232e986e14015d2636732588c687ed71.tar.gz
gentoo-2-d2d06621232e986e14015d2636732588c687ed71.tar.bz2
gentoo-2-d2d06621232e986e14015d2636732588c687ed71.zip
Build shared objects with -fPIC and keyword for ~amd64.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-misc/suxpanel')
-rw-r--r--x11-misc/suxpanel/ChangeLog8
-rw-r--r--x11-misc/suxpanel/files/suxpanel-0.4b-Makefile.in.patch16
-rw-r--r--x11-misc/suxpanel/suxpanel-0.4b.ebuild17
3 files changed, 30 insertions, 11 deletions
diff --git a/x11-misc/suxpanel/ChangeLog b/x11-misc/suxpanel/ChangeLog
index db00936f5b1b..dd1f43023e53 100644
--- a/x11-misc/suxpanel/ChangeLog
+++ b/x11-misc/suxpanel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/suxpanel
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/suxpanel/ChangeLog,v 1.5 2007/03/10 12:27:56 drac Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/suxpanel/ChangeLog,v 1.6 2008/02/18 20:25:43 drac Exp $
+
+ 18 Feb 2008; Samuli Suominen <drac@gentoo.org>
+ files/suxpanel-0.4b-Makefile.in.patch, suxpanel-0.4b.ebuild:
+ Build shared objects with -fPIC and keyword for ~amd64.
*suxpanel-0.4b (10 Mar 2007)
diff --git a/x11-misc/suxpanel/files/suxpanel-0.4b-Makefile.in.patch b/x11-misc/suxpanel/files/suxpanel-0.4b-Makefile.in.patch
index b328b5b2a580..ee42f50541e1 100644
--- a/x11-misc/suxpanel/files/suxpanel-0.4b-Makefile.in.patch
+++ b/x11-misc/suxpanel/files/suxpanel-0.4b-Makefile.in.patch
@@ -1,12 +1,22 @@
diff -ur suxpanel-0.4b.orig/Makefile.in suxpanel-0.4b/Makefile.in
--- suxpanel-0.4b.orig/Makefile.in 2005-07-21 19:06:25.000000000 +0300
-+++ suxpanel-0.4b/Makefile.in 2007-03-10 14:21:28.000000000 +0200
++++ suxpanel-0.4b/Makefile.in 2008-02-18 22:21:37.000000000 +0200
@@ -1,7 +1,7 @@
# ----------------------------------------------------------------------------
- CC = gcc
+-CC = gcc
-CFLAGS = -Wall $(GTK_CFLAGS) -O2 -g
-+CFLAGS := -Wall $(GTK_CFLAGS) $(CFLAGS)
++CC ?= gcc
++CFLAGS += -Wall $(GTK_CFLAGS)
# ----------------------------------------------------------------------------
+@@ -15,7 +15,7 @@
+
+ %.so: %.c
+ @echo "compile module: $< ($@)"
+- $(CC) $(CFLAGS) -o $@ -shared $< $(GTK_CFLAGS) $(GTK_LIBS) \
++ $(CC) $(CFLAGS) -o $@ -shared -fPIC $< $(GTK_CFLAGS) $(GTK_LIBS) \
+ $(WNCK_LIBS) $(WNCK_CFLAGS)
+
+ clean:
diff --git a/x11-misc/suxpanel/suxpanel-0.4b.ebuild b/x11-misc/suxpanel/suxpanel-0.4b.ebuild
index a1d73c8c60b7..19b0795a5123 100644
--- a/x11-misc/suxpanel/suxpanel-0.4b.ebuild
+++ b/x11-misc/suxpanel/suxpanel-0.4b.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/suxpanel/suxpanel-0.4b.ebuild,v 1.1 2007/03/10 12:27:56 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/suxpanel/suxpanel-0.4b.ebuild,v 1.2 2008/02/18 20:25:43 drac Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="SuxPanel is a complete rewrite of MacOS Style Panel, a light-weight X11 desktop panel"
SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
@@ -10,19 +10,24 @@ HOMEPAGE="http://suxpanel.berlios.de"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=x11-libs/gtk+-2
x11-libs/libwnck"
DEPEND="${RDEPEND}
- >=sys-apps/sed-4
dev-util/pkgconfig"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}-Makefile.in.patch"
+ epatch "${FILESDIR}"/${P}-Makefile.in.patch
+}
+
+src_compile() {
+ tc-export CC
+ econf
+ emake || die "emake failed."
}
src_install () {