summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-06-06 18:24:44 +0000
committerBen de Groot <yngwin@gentoo.org>2009-06-06 18:24:44 +0000
commitb009a4f4c09740d0a2daadb9e385f94626ccb523 (patch)
tree5375e16508dd80aba3dbf918c2d4a37f948220f2 /x11-misc/treeline
parentInitial import. (diff)
downloadgentoo-2-b009a4f4c09740d0a2daadb9e385f94626ccb523.tar.gz
gentoo-2-b009a4f4c09740d0a2daadb9e385f94626ccb523.tar.bz2
gentoo-2-b009a4f4c09740d0a2daadb9e385f94626ccb523.zip
Add X use dep for PyQt4, bug 272189. Version bump, with some optimizations in the ebuild.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/treeline')
-rw-r--r--x11-misc/treeline/ChangeLog11
-rw-r--r--x11-misc/treeline/files/treeline-1.2.3-nocompile.patch12
-rw-r--r--x11-misc/treeline/treeline-1.2.2.ebuild7
-rw-r--r--x11-misc/treeline/treeline-1.2.3.ebuild61
4 files changed, 86 insertions, 5 deletions
diff --git a/x11-misc/treeline/ChangeLog b/x11-misc/treeline/ChangeLog
index 3dbb61241073..5f83ebf3b5e9 100644
--- a/x11-misc/treeline/ChangeLog
+++ b/x11-misc/treeline/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/treeline
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/ChangeLog,v 1.36 2009/03/16 11:58:54 pva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/ChangeLog,v 1.37 2009/06/06 18:24:44 yngwin Exp $
+
+*treeline-1.2.3 (06 Jun 2009)
+
+ 06 Jun 2009; Ben de Groot <yngwin@gentoo.org> treeline-1.2.2.ebuild,
+ +treeline-1.2.3.ebuild, +files/treeline-1.2.3-nocompile.patch:
+ Add X use dep for PyQt4, bug 272189. Version bump, with some optimizations
+ in the ebuild.
*treeline-1.2.2 (16 Mar 2009)
diff --git a/x11-misc/treeline/files/treeline-1.2.3-nocompile.patch b/x11-misc/treeline/files/treeline-1.2.3-nocompile.patch
new file mode 100644
index 000000000000..297a926d9091
--- /dev/null
+++ b/x11-misc/treeline/files/treeline-1.2.3-nocompile.patch
@@ -0,0 +1,12 @@
+--- install.py.orig 2009-06-06 19:21:00.000000000 +0200
++++ install.py 2009-06-06 19:26:28.000000000 +0200
+@@ -230,7 +230,8 @@
+ pythonBuildDir = os.path.join(buildRoot, pythonPrefixDir[1:])
+
+ if os.path.isdir('source'):
+- compileall.compile_dir('source', ddir=os.path.join(prefixDir, 'source'))
++ # don't compile, let our eclass handle that
++ # compileall.compile_dir('source', ddir=os.path.join(prefixDir, 'source'))
+ print 'Installing files...'
+ print ' Copying python files to %s' % pythonBuildDir
+ removeDir(pythonBuildDir) # remove old?
diff --git a/x11-misc/treeline/treeline-1.2.2.ebuild b/x11-misc/treeline/treeline-1.2.2.ebuild
index f03b0709c58b..7278f9ba138a 100644
--- a/x11-misc/treeline/treeline-1.2.2.ebuild
+++ b/x11-misc/treeline/treeline-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/treeline-1.2.2.ebuild,v 1.2 2009/03/17 06:27:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/treeline-1.2.2.ebuild,v 1.3 2009/06/06 18:24:44 yngwin Exp $
EAPI=2
inherit python
@@ -22,7 +22,8 @@ done
DEPEND="spell? ( || ( app-text/aspell app-text/ispell ) )
>=dev-lang/python-2.3[xml]
- >=dev-python/PyQt4-4.1"
+ dev-python/PyQt4[X]"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/TreeLine
@@ -30,7 +31,7 @@ src_unpack() {
unpack ${P}.tar.gz
for lang in ${LANGS}; do
if use linguas_${lang}; then
- tar xozf ${DISTDIR}/${PN}-i18n-${PV}a.tar.gz \
+ tar xozf "${DISTDIR}"/${PN}-i18n-${PV}a.tar.gz \
TreeLine/doc/{readme_${lang}.trl,README_${lang}.html} \
TreeLine/translations/{treeline_${lang}.{qm,ts},qt_${lang}.{qm,ts}} || die
fi
diff --git a/x11-misc/treeline/treeline-1.2.3.ebuild b/x11-misc/treeline/treeline-1.2.3.ebuild
new file mode 100644
index 000000000000..42521e0e4a72
--- /dev/null
+++ b/x11-misc/treeline/treeline-1.2.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/treeline-1.2.3.ebuild,v 1.1 2009/06/06 18:24:44 yngwin Exp $
+
+EAPI=2
+NEED_PYTHON="2.4"
+PYTHON_USE_WITH="xml"
+
+inherit eutils python
+
+DESCRIPTION="TreeLine is a structured information storage program."
+HOMEPAGE="http://treeline.bellz.org/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="spell"
+
+LANGS="de fr"
+for lang in ${LANGS}; do
+ IUSE="${IUSE} linguas_${lang}"
+ SRC_URI="${SRC_URI} linguas_${lang}? ( mirror://berlios/${PN}/${PN}-i18n-${PV}a.tar.gz )"
+done
+
+DEPEND="spell? ( || ( app-text/aspell app-text/ispell ) )
+ dev-python/PyQt4[X]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/TreeLine"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ for lang in ${LANGS}; do
+ if use linguas_${lang}; then
+ tar xozf "${DISTDIR}"/${PN}-i18n-${PV}a.tar.gz \
+ TreeLine/doc/{readme_${lang}.trl,README_${lang}.html} \
+ TreeLine/translations/{treeline_${lang}.{qm,ts},qt_${lang}.{qm,ts}} || die
+ fi
+ done
+}
+
+src_prepare() {
+ # let's leave compiling to python_mod_optimize
+ epatch "${FILESDIR}"/${P}-nocompile.patch
+
+ # install into proper python site-packages dir
+ sed -i "s;prefixDir, 'lib;'$(python_get_sitedir);" install.py || die 'sed failed'
+}
+
+src_install() {
+ "${python}" install.py -x -p /usr/ -d /usr/share/${PF} -b "${D}"
+}
+
+pkg_postinst() {
+ python_mod_optimize "$(python_get_sitedir)/${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}