summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-09-03 06:20:21 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-09-03 06:20:21 +0000
commitc387d771e7f4d742b977d47634daa68f60620e16 (patch)
treebe2ae67d17a891090bfaf74452b04d6b8892a9aa /x11-misc/x2x
parentVersion Bump (diff)
downloadgentoo-2-c387d771e7f4d742b977d47634daa68f60620e16.tar.gz
gentoo-2-c387d771e7f4d742b977d47634daa68f60620e16.tar.bz2
gentoo-2-c387d771e7f4d742b977d47634daa68f60620e16.zip
Respect CC,CFLAGS,LDFLAGS wrt bug 335701. Thanks to Diego for the report and Ross Smith <gaurdro@gmail.com> for patch.
(Portage version: 2.2_rc73/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/x2x')
-rw-r--r--x11-misc/x2x/ChangeLog10
-rw-r--r--x11-misc/x2x/x2x-1.27-r3.ebuild58
2 files changed, 66 insertions, 2 deletions
diff --git a/x11-misc/x2x/ChangeLog b/x11-misc/x2x/ChangeLog
index b95ab337ce59..d209b86b4d92 100644
--- a/x11-misc/x2x/ChangeLog
+++ b/x11-misc/x2x/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/x2x
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x2x/ChangeLog,v 1.22 2008/02/21 14:25:57 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x2x/ChangeLog,v 1.23 2010/09/03 06:20:21 xarthisius Exp $
+
+*x2x-1.27-r3 (03 Sep 2010)
+
+ 03 Sep 2010; Kacper Kowalik <xarthisius@gentoo.org> +x2x-1.27-r3.ebuild:
+ Respect CC,CFLAGS,LDFLAGS wrt bug 335701. Thanks to Diego for the report
+ and Ross Smith <gaurdro@gmail.com> for patch.
21 Feb 2008; Raúl Porcel <armin76@gentoo.org> x2x-1.27-r2.ebuild:
alpha/sparc/x86 stable
diff --git a/x11-misc/x2x/x2x-1.27-r3.ebuild b/x11-misc/x2x/x2x-1.27-r3.ebuild
new file mode 100644
index 000000000000..7729f1bf471f
--- /dev/null
+++ b/x11-misc/x2x/x2x-1.27-r3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x2x/x2x-1.27-r3.ebuild,v 1.1 2010/09/03 06:20:21 xarthisius Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An utility to connect the Mouse and KeyBoard to another X"
+HOMEPAGE="http://www.the-labs.com/X11/#x2x"
+LICENSE="as-is"
+SRC_URI="http://ftp.digital.com/pub/Digital/SRC/x2x/${P}.tar.gz
+ mirror://debian/pool/main/x/x2x/x2x_1.27-8.diff.gz
+ mirror://gentoo/x2x_1.27-8-initvars.patch.gz
+ mirror://gentoo/${P}-license.patch.gz
+ mirror://gentoo/${P}-keymap.diff.gz"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXtst
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ app-text/rman
+ x11-misc/imake
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Patch from Debian to add -north and -south, among other fixes
+ epatch "${DISTDIR}"/x2x_1.27-8.diff.gz
+
+ # Fix variable initialization in Debian patch
+ epatch "${DISTDIR}"/x2x_1.27-8-initvars.patch.gz
+
+ # Patch to add LICENSE
+ epatch "${DISTDIR}"/${P}-license.patch.gz
+
+ # Patch to fix bug #126939
+ # AltGr does not work in x2x with different keymaps:
+ epatch "${DISTDIR}"/${P}-keymap.diff.gz
+
+ # Man-page is packaged as x2x.1 but needs to be x2x.man for building
+ mv x2x.1 x2x.man || die
+}
+
+src_compile() {
+ xmkmf || die
+ emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" || die
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+ newman x2x.man x2x.1 || die
+}