summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2007-02-18 06:54:01 +0000
committerJoseph Jezak <josejx@gentoo.org>2007-02-18 06:54:01 +0000
commitd018e93ab600c2d7e571a7566efad72e101d196a (patch)
treeb67e169c5262a485e779ac2771616cc86f56936f /x11-misc/xac
parentRemoved old versions. (diff)
downloadgentoo-2-d018e93ab600c2d7e571a7566efad72e101d196a.tar.gz
gentoo-2-d018e93ab600c2d7e571a7566efad72e101d196a.tar.bz2
gentoo-2-d018e93ab600c2d7e571a7566efad72e101d196a.zip
New version, x86 fixes.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'x11-misc/xac')
-rw-r--r--x11-misc/xac/ChangeLog7
-rw-r--r--x11-misc/xac/files/digest-xac-0.6_pre23
-rw-r--r--x11-misc/xac/xac-0.6_pre2.ebuild54
3 files changed, 63 insertions, 1 deletions
diff --git a/x11-misc/xac/ChangeLog b/x11-misc/xac/ChangeLog
index 3bb636d6032e..cd91387ee60c 100644
--- a/x11-misc/xac/ChangeLog
+++ b/x11-misc/xac/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xac
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xac/ChangeLog,v 1.5 2007/02/13 00:58:48 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xac/ChangeLog,v 1.6 2007/02/18 06:54:01 josejx Exp $
+
+*xac-0.6_pre2 (18 Feb 2007)
+
+ 18 Feb 2007; Joseph Jezak <josejx@gentoo.org> +xac-0.6_pre2.ebuild:
+ New version, x86 fixes.
13 Feb 2007; Joseph Jezak <josejx@gentoo.org> +files/xac-lz.patch,
xac-0.6_pre1.ebuild:
diff --git a/x11-misc/xac/files/digest-xac-0.6_pre2 b/x11-misc/xac/files/digest-xac-0.6_pre2
new file mode 100644
index 000000000000..6bafce5e0dbd
--- /dev/null
+++ b/x11-misc/xac/files/digest-xac-0.6_pre2
@@ -0,0 +1,3 @@
+MD5 709bb20a464a9293860cfbfe716c8907 xac-0.6_pre2.tar.bz2 37261
+RMD160 520a0671eb329f7be0ba8f47ca5ce2a9982bb947 xac-0.6_pre2.tar.bz2 37261
+SHA256 d2240d5ccb7fc6a1e15e072841add08f11d8651eae26771525e15653a246f330 xac-0.6_pre2.tar.bz2 37261
diff --git a/x11-misc/xac/xac-0.6_pre2.ebuild b/x11-misc/xac/xac-0.6_pre2.ebuild
new file mode 100644
index 000000000000..bf49f6a5b17f
--- /dev/null
+++ b/x11-misc/xac/xac-0.6_pre2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xac/xac-0.6_pre2.ebuild,v 1.1 2007/02/18 06:54:01 josejx Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Xorgautoconfig (xac) generates configuration files for X.org"
+HOMEPAGE="http://dev.gentoo.org/~josejx/xac.html"
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/python-2.3
+ sys-apps/pciutils"
+RDEPEND=">=dev-lang/python-2.3
+ || ( x11-base/xorg-server virtual/x11 )"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ ### Replace /usr/lib/xac with libdir version
+ sed -i "s:/usr/lib/xac:/usr/$(get_libdir)/xac:" xac
+}
+
+src_compile() {
+ ### Compile the C bindings
+ cd "${S}"/src
+ ### I'm not sure of a better way to do this yet
+ if use x86; then
+ sed -i "s:if 1:if 0:" setup.py || die "Enabling VBE module failed!"
+ fi
+ ./setup.py build || die "Failed to build the C modules"
+}
+
+src_install() {
+ local xac_base="/usr/$(get_libdir)/xac"
+
+ dosbin "${S}"/xac
+
+ ### Install the C mods
+ cd "${S}"/src
+ ./setup.py install --root "${D}" || die "Failed to install the C modules"
+
+ dodir "${xac_base}"
+ insinto ${xac_base}
+ doins "${S}"/py/*
+
+ exeinto /etc/init.d
+ newexe "${S}"/xac.init xac
+ insinto /etc/conf.d
+ newins "${S}"/xac.conf xac
+}