summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-08 18:20:05 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-08 18:20:05 +0000
commit13c47f4365f817078cd8ed856dd1baef51afebf3 (patch)
tree79f1ece073d87049ae05ad303fffe36d3630eb05 /x11-misc/xbindkeys
parentppc stable #290464 (diff)
downloadgentoo-2-13c47f4365f817078cd8ed856dd1baef51afebf3.tar.gz
gentoo-2-13c47f4365f817078cd8ed856dd1baef51afebf3.tar.bz2
gentoo-2-13c47f4365f817078cd8ed856dd1baef51afebf3.zip
Drop built_with_use.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'x11-misc/xbindkeys')
-rw-r--r--x11-misc/xbindkeys/ChangeLog6
-rw-r--r--x11-misc/xbindkeys/xbindkeys-1.7.3.ebuild27
-rw-r--r--x11-misc/xbindkeys/xbindkeys-1.8.0.ebuild27
-rw-r--r--x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild25
4 files changed, 37 insertions, 48 deletions
diff --git a/x11-misc/xbindkeys/ChangeLog b/x11-misc/xbindkeys/ChangeLog
index 168bdfffbfc4..679a8696a372 100644
--- a/x11-misc/xbindkeys/ChangeLog
+++ b/x11-misc/xbindkeys/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xbindkeys
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/ChangeLog,v 1.51 2010/02/08 18:11:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/ChangeLog,v 1.52 2010/02/08 18:20:05 jer Exp $
+
+ 08 Feb 2010; Jeroen Roovers <jer@gentoo.org> xbindkeys-1.7.3.ebuild,
+ xbindkeys-1.8.0.ebuild, xbindkeys-1.8.3.ebuild:
+ Drop built_with_use.
*xbindkeys-1.8.3 (08 Feb 2010)
diff --git a/x11-misc/xbindkeys/xbindkeys-1.7.3.ebuild b/x11-misc/xbindkeys/xbindkeys-1.7.3.ebuild
index 9882dab4276a..0da1db844c05 100644
--- a/x11-misc/xbindkeys/xbindkeys-1.7.3.ebuild
+++ b/x11-misc/xbindkeys/xbindkeys-1.7.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/xbindkeys-1.7.3.ebuild,v 1.11 2007/07/22 03:27:42 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/xbindkeys-1.7.3.ebuild,v 1.12 2010/02/08 18:20:05 jer Exp $
+
+EAPI="2"
inherit eutils
@@ -15,30 +17,23 @@ KEYWORDS="amd64 ppc ppc64 sparc x86"
SLOT="0"
RDEPEND="x11-libs/libX11
- guile? ( dev-scheme/guile )
+ guile? ( >=dev-scheme/guile-1.8.4[deprecated] )
tk? ( dev-lang/tk )"
DEPEND="${RDEPEND}
x11-proto/xproto"
-pkg_setup() {
- if use guile && has_version ">=dev-scheme/guile-1.8" \
- && ! built_with_use ">=dev-scheme/guile-1.8" deprecated
- then
- eerror "In order to compile xbindkeys with guile-1.8 or higher, you need"
- eerror "to recompile dev-scheme/guile with the \"deprecated\" USE flag."
- die "Please re-emerge dev-scheme/guile with USE=\"deprecated\"."
- fi
-}
-
-src_compile() {
+src_configure() {
local myconf
use tk || myconf="${myconf} --disable-tk"
use guile || myconf="${myconf} --disable-guile"
econf ${myconf} || die "configure failed"
- emake DESTDIR=${D} || die "make failed"
+}
+
+src_compile() {
+ emake DESTDIR="${D}" || die "make failed"
}
src_install() {
- make DESTDIR=${D} BINDIR=/usr/bin install || die "make install failed"
+ make DESTDIR="${D}" BINDIR=/usr/bin install || die "make install failed"
}
diff --git a/x11-misc/xbindkeys/xbindkeys-1.8.0.ebuild b/x11-misc/xbindkeys/xbindkeys-1.8.0.ebuild
index eeabb9941f5a..d5637539ff0d 100644
--- a/x11-misc/xbindkeys/xbindkeys-1.8.0.ebuild
+++ b/x11-misc/xbindkeys/xbindkeys-1.8.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/xbindkeys-1.8.0.ebuild,v 1.5 2007/08/06 19:36:39 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/xbindkeys-1.8.0.ebuild,v 1.6 2010/02/08 18:20:05 jer Exp $
+
+EAPI="2"
inherit eutils
@@ -15,30 +17,23 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
SLOT="0"
RDEPEND="x11-libs/libX11
- guile? ( dev-scheme/guile )
+ guile? ( >=dev-scheme/guile-1.8.4[deprecated] )
tk? ( dev-lang/tk )"
DEPEND="${RDEPEND}
x11-proto/xproto"
-pkg_setup() {
- if use guile && has_version ">=dev-scheme/guile-1.8" \
- && ! built_with_use ">=dev-scheme/guile-1.8" deprecated
- then
- eerror "In order to compile xbindkeys with guile-1.8 or higher, you need"
- eerror "to recompile dev-scheme/guile with the \"deprecated\" USE flag."
- die "Please re-emerge dev-scheme/guile with USE=\"deprecated\"."
- fi
-}
-
-src_compile() {
+src_configure() {
local myconf
use tk || myconf="${myconf} --disable-tk"
use guile || myconf="${myconf} --disable-guile"
econf ${myconf} || die "configure failed"
- emake DESTDIR=${D} || die "make failed"
+}
+
+src_compile() {
+ emake DESTDIR="${D}" || die "make failed"
}
src_install() {
- make DESTDIR=${D} BINDIR=/usr/bin install || die "make install failed"
+ make DESTDIR="${D}" BINDIR=/usr/bin install || die "make install failed"
}
diff --git a/x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild b/x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild
index bc66e8278a3f..ea451075d78d 100644
--- a/x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild
+++ b/x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild,v 1.1 2010/02/08 18:11:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild,v 1.2 2010/02/08 18:20:05 jer Exp $
+
+EAPI="2"
inherit eutils
@@ -15,30 +17,23 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
SLOT="0"
RDEPEND="x11-libs/libX11
- guile? ( dev-scheme/guile )
+ guile? ( >=dev-scheme/guile-1.8.4[deprecated] )
tk? ( dev-lang/tk )"
DEPEND="${RDEPEND}
x11-proto/xproto"
-pkg_setup() {
- if use guile && has_version ">=dev-scheme/guile-1.8" \
- && ! built_with_use ">=dev-scheme/guile-1.8" deprecated
- then
- eerror "In order to compile xbindkeys with guile-1.8 or higher, you need"
- eerror "to recompile dev-scheme/guile with the \"deprecated\" USE flag."
- die "Please re-emerge dev-scheme/guile with USE=\"deprecated\"."
- fi
-}
-
-src_compile() {
+src_configure() {
local myconf
use tk || myconf="${myconf} --disable-tk"
use guile || myconf="${myconf} --disable-guile"
econf ${myconf} || die "configure failed"
- emake DESTDIR=${D} || die "make failed"
+}
+
+src_compile() {
+ emake DESTDIR="${D}" || die "make failed"
}
src_install() {
- make DESTDIR=${D} BINDIR=/usr/bin install || die "make install failed"
+ make DESTDIR="${D}" BINDIR=/usr/bin install || die "make install failed"
}