summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2011-07-03 12:00:22 +0000
committerChristian Birchinger <joker@gentoo.org>2011-07-03 12:00:22 +0000
commit25a6ca1bb82fbcf4ba1ff0fd2d76b9eafc0d1b12 (patch)
treea2b3b4aa53cd54a5d32f5e72f6d1df916b32a7b0 /x11-misc/xdotool
parentsys-boot/plymouth-openrc-plugin-0.1.1: weak block <sys-boot/plymouth-0.8.3-r5 (diff)
downloadgentoo-2-25a6ca1bb82fbcf4ba1ff0fd2d76b9eafc0d1b12.tar.gz
gentoo-2-25a6ca1bb82fbcf4ba1ff0fd2d76b9eafc0d1b12.tar.bz2
gentoo-2-25a6ca1bb82fbcf4ba1ff0fd2d76b9eafc0d1b12.zip
Version bump
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xdotool')
-rw-r--r--x11-misc/xdotool/ChangeLog8
-rw-r--r--x11-misc/xdotool/xdotool-2.20110530.1.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-misc/xdotool/ChangeLog b/x11-misc/xdotool/ChangeLog
index 0f777f11ea7b..8ab64ce1d03d 100644
--- a/x11-misc/xdotool/ChangeLog
+++ b/x11-misc/xdotool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xdotool
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/ChangeLog,v 1.20 2011/03/28 13:33:33 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/ChangeLog,v 1.21 2011/07/03 12:00:22 joker Exp $
+
+*xdotool-2.20110530.1 (03 Jul 2011)
+
+ 03 Jul 2011; Christian Birchinger <joker@gentoo.org>
+ +xdotool-2.20110530.1.ebuild:
+ Version bump
28 Mar 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
xdotool-2.20101012.3049.ebuild:
diff --git a/x11-misc/xdotool/xdotool-2.20110530.1.ebuild b/x11-misc/xdotool/xdotool-2.20110530.1.ebuild
new file mode 100644
index 000000000000..98218133a91b
--- /dev/null
+++ b/x11-misc/xdotool/xdotool-2.20110530.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/xdotool-2.20110530.1.ebuild,v 1.1 2011/07/03 12:00:22 joker Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs flag-o-matic multilib
+
+DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows."
+HOMEPAGE="http://www.semicomplete.com/projects/xdotool/"
+SRC_URI="http://semicomplete.googlecode.com/files/${P}.tar.gz"
+LICENSE="as-is"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="x11-libs/libXtst
+ x11-libs/libX11"
+
+RDEPEND="${DEPEND}"
+
+# The test wants to manualy start Xvfb, wont use VirtualX and it tries
+# to run a full gnome-session. For such a tiny application i consider
+# it overkill to rewrite the test scripts to not use it's own X server
+# and add a full blown gnome just to run the tests.
+RESTRICT="test"
+
+src_prepare() {
+ sed -e "s/installheader post-install$/installheader/" \
+ -i Makefile || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC LD
+ default
+}
+
+src_install() {
+ emake PREFIX="${D}usr" INSTALLMAN="${D}usr/share/man" INSTALLLIB="${D}usr/$(get_libdir)" install || die
+
+ dodoc CHANGELIST README
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}