summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-14 14:54:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-14 14:54:59 +0000
commit42930999ff78d4f43658bcb4c2e1ab5cb6a5f396 (patch)
tree699f9209e667c4fb77a451b4f07273eb4bbc6086 /x11-misc/xlockmore
parentVersion bump, patch merged upstream. (diff)
downloadgentoo-2-42930999ff78d4f43658bcb4c2e1ab5cb6a5f396.tar.gz
gentoo-2-42930999ff78d4f43658bcb4c2e1ab5cb6a5f396.tar.bz2
gentoo-2-42930999ff78d4f43658bcb4c2e1ab5cb6a5f396.zip
Version bump wrt #301053 by Tim Harder.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xlockmore')
-rw-r--r--x11-misc/xlockmore/ChangeLog10
-rw-r--r--x11-misc/xlockmore/xlockmore-5.29.1.ebuild79
2 files changed, 87 insertions, 2 deletions
diff --git a/x11-misc/xlockmore/ChangeLog b/x11-misc/xlockmore/ChangeLog
index 9909348e224d..b348896bf2e2 100644
--- a/x11-misc/xlockmore/ChangeLog
+++ b/x11-misc/xlockmore/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xlockmore
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/ChangeLog,v 1.79 2009/08/10 15:10:39 klausman Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/ChangeLog,v 1.80 2010/02/14 14:54:59 ssuominen Exp $
+
+*xlockmore-5.29.1 (14 Feb 2010)
+
+ 14 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +xlockmore-5.29.1.ebuild:
+ Version bump wrt #301053 by Tim Harder.
10 Aug 2009; Tobias Klausmann <klausman@gentoo.org> xlockmore-5.28.ebuild:
Stable on alpha, bug #266937
diff --git a/x11-misc/xlockmore/xlockmore-5.29.1.ebuild b/x11-misc/xlockmore/xlockmore-5.29.1.ebuild
new file mode 100644
index 000000000000..f6b185edd0ea
--- /dev/null
+++ b/x11-misc/xlockmore/xlockmore-5.29.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/xlockmore-5.29.1.ebuild,v 1.1 2010/02/14 14:54:59 ssuominen Exp $
+
+EAPI=2
+inherit flag-o-matic pam
+
+DESCRIPTION="Just another screensaver application for X"
+HOMEPAGE="http://www.tux.org/~bagleyd/xlockmore.html"
+SRC_URI="http://ftp.tux.org/pub/tux/bagleyd/${PN}/${P}/${P}.tar.bz2"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt debug esd gtk motif nas opengl pam truetype xinerama xlockrc"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libXt
+ x11-libs/libXmu
+ opengl? ( media-libs/mesa
+ truetype? ( >=media-libs/ftgl-2.1.3_rc5 ) )
+ truetype? ( media-libs/freetype:2 )
+ pam? ( virtual/pam )
+ nas? ( media-libs/nas )
+ esd? ( media-sound/esound )
+ motif? ( x11-libs/openmotif )
+ gtk? ( x11-libs/gtk+:2 )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xineramaproto"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_configure() {
+ local myconf=""
+
+ if use opengl && use truetype; then
+ myconf="${myconf} --with-ftgl"
+ append-flags -DFTGL213
+ else
+ myconf="${myconf} --without-ftgl"
+ fi
+
+ econf \
+ --enable-vtlock \
+ --enable-syslog \
+ $(use_enable xlockrc) \
+ $(use_enable pam) \
+ --disable-use-mb \
+ --enable-appdefaultdir=/usr/share/X11/app-defaults \
+ $(use_with motif) \
+ $(use_with debug editres) \
+ $(use_with truetype ttf) \
+ $(use_with truetype freetype) \
+ $(use_with opengl) \
+ $(use_with opengl mesa) \
+ $(use_with xinerama) \
+ $(use_with esd esound) \
+ $(use_with nas) \
+ $(use_with crypt) \
+ $(use_with gtk gtk2) \
+ --without-gtk \
+ ${myconf}
+}
+
+src_install() {
+ einstall xapploaddir="${D}/usr/share/X11/app-defaults" \
+ mandir="${D}/usr/share/man/man1" INSTPGMFLAGS="" \
+ || die "einstall failed"
+
+ pamd_mimic_system xlock auth
+ use pam && fperms 755 /usr/bin/xlock
+
+ dohtml docs/xlock.html
+ dodoc README docs/{3d.howto,cell_automata,HACKERS.GUIDE,Purify,Revisions,TODO}
+}