summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-09-18 18:09:00 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-09-18 18:09:00 +0000
commit6ee47703c7fc63e44aff75c73567da797bc2f19a (patch)
tree9069e031ad18af236c77d5f1be0ad132096d31fa /x11-misc/xmobar
parentInitial version. Haskell bindings to the ALSA simple mixer API. (diff)
downloadgentoo-2-6ee47703c7fc63e44aff75c73567da797bc2f19a.tar.gz
gentoo-2-6ee47703c7fc63e44aff75c73567da797bc2f19a.tar.bz2
gentoo-2-6ee47703c7fc63e44aff75c73567da797bc2f19a.zip
Version bump. Requested by Aleksander Alistra Balicki and by Dan Douglas (bug #351624)
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xmobar')
-rw-r--r--x11-misc/xmobar/ChangeLog8
-rw-r--r--x11-misc/xmobar/xmobar-0.13.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/x11-misc/xmobar/ChangeLog b/x11-misc/xmobar/ChangeLog
index 02eb44485d10..982a75f5bdaa 100644
--- a/x11-misc/xmobar/ChangeLog
+++ b/x11-misc/xmobar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xmobar
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/ChangeLog,v 1.11 2011/05/11 21:10:40 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/ChangeLog,v 1.12 2011/09/18 18:09:00 slyfox Exp $
+
+*xmobar-0.13 (18 Sep 2011)
+
+ 18 Sep 2011; Sergei Trofimovich <slyfox@gentoo.org> +xmobar-0.13.ebuild:
+ Version bump. Requested by Aleksander "Alistra" Balicki and by Dan Douglas
+ (bug #351624)
11 May 2011; Sergei Trofimovich <slyfox@gentoo.org> -xmobar-0.8.ebuild,
-xmobar-0.8-r1.ebuild, -xmobar-0.9.ebuild, -xmobar-0.9.2-r1.ebuild:
diff --git a/x11-misc/xmobar/xmobar-0.13.ebuild b/x11-misc/xmobar/xmobar-0.13.ebuild
new file mode 100644
index 000000000000..a84842f92b5e
--- /dev/null
+++ b/x11-misc/xmobar/xmobar-0.13.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/xmobar-0.13.ebuild,v 1.1 2011/09/18 18:09:00 slyfox Exp $
+
+EAPI="3"
+CABAL_FEATURES="bin"
+inherit haskell-cabal
+
+DESCRIPTION="A Minimalistic Text Based Status Bar"
+HOMEPAGE="http://projects.haskell.org/xmobar/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="xft unicode mail alsa"
+# wifi USE flag disabled due to compilation error with current stable wireless-tools.
+# mpd is disabled as it requires mtl-2 (not in tree)
+
+DEPEND=">=dev-lang/ghc-6.8.1
+ >=dev-haskell/cabal-1.6
+ dev-haskell/mtl
+ dev-haskell/parsec
+ dev-haskell/stm
+ dev-haskell/time
+ >=dev-haskell/x11-1.3.0
+ unicode? ( dev-haskell/utf8-string )
+ xft? ( dev-haskell/utf8-string
+ dev-haskell/x11-xft )
+ mail? ( dev-haskell/hinotify )
+ alsa? ( >=dev-haskell/alsa-mixer-0.1 )"
+# mpd? ( >=dev-haskell/libmpd-0.5 )
+# wifi? ( net-wireless/wireless-tools )
+#RDEPEND="mpd? ( media-sound/mpd )"
+RDEPEND=""
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag xft with_xft) \
+ $(cabal_flag unicode with_utf8) \
+ $(cabal_flag mail with_inotify) \
+ $(cabal_flag alsa with_alsa)
+# $(cabal_flag mpd with_mpd) \
+# $(cabal_flag wifi with_iwlib) \
+}
+
+src_install() {
+ cabal_src_install
+
+ dodoc samples/xmobar.config README
+}