summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-02-03 18:06:38 +0000
committerSamuli Suominen <drac@gentoo.org>2008-02-03 18:06:38 +0000
commit3f04dcf4b8389df7dc33c4f10c7e051e3ea8d680 (patch)
treef8c6fc7590d6bba4284d70816c61728efdf75061 /x11-misc/xnee
parentfix for making clisp-link executable, bug 205387 (diff)
downloadgentoo-2-3f04dcf4b8389df7dc33c4f10c7e051e3ea8d680.tar.gz
gentoo-2-3f04dcf4b8389df7dc33c4f10c7e051e3ea8d680.tar.bz2
gentoo-2-3f04dcf4b8389df7dc33c4f10c7e051e3ea8d680.zip
Version bump with keyword for ~amd64.
(Portage version: 2.1.4.1)
Diffstat (limited to 'x11-misc/xnee')
-rw-r--r--x11-misc/xnee/ChangeLog10
-rw-r--r--x11-misc/xnee/files/xnee-3.02-destdir.patch14
-rw-r--r--x11-misc/xnee/xnee-3.02.ebuild55
3 files changed, 77 insertions, 2 deletions
diff --git a/x11-misc/xnee/ChangeLog b/x11-misc/xnee/ChangeLog
index 910e16f34c8f..956e28563c5e 100644
--- a/x11-misc/xnee/ChangeLog
+++ b/x11-misc/xnee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xnee
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnee/ChangeLog,v 1.2 2007/08/14 15:44:42 drac Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnee/ChangeLog,v 1.3 2008/02/03 18:06:37 drac Exp $
+
+*xnee-3.02 (03 Feb 2008)
+
+ 03 Feb 2008; Samuli Suominen <drac@gentoo.org>
+ +files/xnee-3.02-destdir.patch, +xnee-3.02.ebuild:
+ Version bump with keyword for ~amd64.
14 Aug 2007; Samuli Suominen <drac@gentoo.org> xnee-3.01.ebuild:
Add desktop entry with icon.
diff --git a/x11-misc/xnee/files/xnee-3.02-destdir.patch b/x11-misc/xnee/files/xnee-3.02-destdir.patch
new file mode 100644
index 000000000000..7c1cb3bf3c60
--- /dev/null
+++ b/x11-misc/xnee/files/xnee-3.02-destdir.patch
@@ -0,0 +1,14 @@
+diff -ur xnee-3.02.orig/doc/Makefile.in xnee-3.02/doc/Makefile.in
+--- xnee-3.02.orig/doc/Makefile.in 2007-10-30 10:56:57.000000000 +0200
++++ xnee-3.02/doc/Makefile.in 2008-02-03 19:48:14.000000000 +0200
+@@ -623,8 +623,8 @@
+ ${IMG_JPG}: ${IMG_EPS}
+
+ install:
+- mkdir -p $(docdir)
+- cp $(MANUALS) $(GEN_IMAGES_TO_INSTALL) $(docdir)/
++ mkdir -p $(DESTDIR)$(docdir)
++ cp $(MANUALS) $(GEN_IMAGES_TO_INSTALL) $(DESTDIR)$(docdir)/
+
+ api-doc: xnee.dox
+ \rm -fr alldocs/
diff --git a/x11-misc/xnee/xnee-3.02.ebuild b/x11-misc/xnee/xnee-3.02.ebuild
new file mode 100644
index 000000000000..43605b7e3c19
--- /dev/null
+++ b/x11-misc/xnee/xnee-3.02.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnee/xnee-3.02.ebuild,v 1.1 2008/02/03 18:06:37 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="Program suite to record, replay and distribute user actions."
+HOMEPAGE="http://www.sandklef.com/xnee"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome gtk xosd"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXtst
+ gtk? ( >=x11-libs/gtk+-2 )
+ gnome? ( gnome-base/gconf
+ gnome-base/gnome-panel )"
+DEPEND="sys-apps/sed
+ dev-util/pkgconfig
+ gtk? ( sys-devel/gettext media-gfx/imagemagick )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-destdir.patch
+}
+
+src_compile() {
+ local myconf
+
+ if use xosd; then
+ myconf="--enable-xosd --enable-verbose --enable-buffer_verbose"
+ else
+ myconf="--disable-xosd --disable-verbose --disable-buffer_verbose"
+ fi
+
+ econf ${myconf} --enable-cli --enable-lib \
+ $(use_enable gnome gnome-applet) \
+ $(use_enable gtk gui)
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS BUGS ChangeLog FAQ NEWS README TODO
+
+ if use gtk; then
+ doicon pixmap/${PN}.png
+ make_desktop_entry gnee Gnee ${PN} "Utility;GTK"
+ fi
+}