summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-07-07 10:05:16 +0000
committerTilman Klar <phoenix@gentoo.org>2002-07-07 10:05:16 +0000
commita7f625c8589b106741e48c382fa26290f35c693d (patch)
tree300ac742749dd73c84a9d77d330e5316e5ade3b2 /x11-misc/xscreensaver/xscreensaver-4.05-r3.ebuild
parentAdded feature to init script and added SLOT's and LICENSE lines. (diff)
downloadgentoo-2-a7f625c8589b106741e48c382fa26290f35c693d.tar.gz
gentoo-2-a7f625c8589b106741e48c382fa26290f35c693d.tar.bz2
gentoo-2-a7f625c8589b106741e48c382fa26290f35c693d.zip
Bumping to new version.
Diffstat (limited to 'x11-misc/xscreensaver/xscreensaver-4.05-r3.ebuild')
-rw-r--r--x11-misc/xscreensaver/xscreensaver-4.05-r3.ebuild99
1 files changed, 99 insertions, 0 deletions
diff --git a/x11-misc/xscreensaver/xscreensaver-4.05-r3.ebuild b/x11-misc/xscreensaver/xscreensaver-4.05-r3.ebuild
new file mode 100644
index 000000000000..eef3998bbbb8
--- /dev/null
+++ b/x11-misc/xscreensaver/xscreensaver-4.05-r3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xscreensaver/xscreensaver-4.05-r3.ebuild,v 1.1 2002/07/07 10:05:16 phoenix Exp $
+
+DESCRIPTION="a modular screensaver for X11"
+SRC_URI="http://www.jwz.org/xscreensaver/${P}.tar.gz"
+HOMEPAGE="http://www.jwz.org/xscreensaver/"
+KEYWORDS="x86"
+SLOT="0"
+
+DEPEND="virtual/x11 sys-devel/bc
+ gtk? ( x11-libs/gtk+ )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ opengl? ( virtual/opengl >=media-libs/gle-3.0.1 )
+ gnome? ( media-libs/gdk-pixbuf
+ >=gnome-base/control-center-1.4.0.1-r1 )
+ pam? ( >=sys-libs/pam-0.75 )
+ dev-libs/libxml2"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ #use nls && ( \
+ # cd po
+ # patch -p0 < ${FILESDIR}/${P}-gentoo.diff
+ #) || ( \
+ cp Makefile.in Makefile.in.orig
+ sed "s:hacks/glx po:hacks/glx:" \
+ Makefile.in.orig > Makefile.in
+ #)
+}
+
+src_compile() {
+ local myconf=""
+ use gnome \
+ && myconf="${myconf} --with-gnome" \
+ || myconf="${myconf} --without-gnome"
+
+ use gtk \
+ && myconf="${myconf} --with-gtk" \
+ || myconf="${myconf} --without-gtk"
+
+ use motif \
+ && myconf="${myconf} --with-motif" \
+ || myconf="${myconf} --without-motif"
+
+ use pam \
+ && myconf="${myconf} --with-pam" \
+ || myconf="${myconf} --without-pam"
+
+ use opengl \
+ && myconf="${myconf} --with-gl --with-gle" \
+ || myconf="${myconf} --without-gl --without-gle"
+
+ export C_INCLUDE_PATH="/usr/include/libxml2/libxml/"
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host="${CHOST}" \
+ --enable-hackdir=/usr/lib/xscreensaver \
+ --with-mit-ext \
+ --with-dpms-ext \
+ --with-xinerama-ext \
+ --with-xf86vmode-ext \
+ --with-xf86gamma-ext \
+ --with-proc-interrupts \
+ --with-xpm \
+ --with-xshm-ext \
+ --with-xdbe-ext \
+ --enable-locking \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ [ -n "$KDEDIR" ] && dodir "$KDEDIR/bin"
+
+ make install_prefix="${D}" install || die
+ # install correctly in gnome2
+ use gnome && ( \
+ dodir /usr/share/gnome/capplets
+ insinto /usr/share/gnome/capplets
+ doins "driver/screensaver-properties.desktop"
+ )
+
+ use gnome && ( \
+ insinto /usr/share/pixmaps
+ newins ${S}/utils/images/logo-50.xpm xscreensaver.xpm
+ )
+
+ use pam && ( \
+ insinto /etc/pam.d
+ doins "${FILESDIR}/pam.d/xscreensaver"
+ )
+}