summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2008-02-18 00:29:59 +0000
committerDavid Shakaryan <omp@gentoo.org>2008-02-18 00:29:59 +0000
commit42c3704ea155c9761dd27126ef8884a3bebe9522 (patch)
tree5c57b63ccb2309ab3167b4a687517c37fbc48e8f /x11-misc
parentVersion bump. (diff)
downloadgentoo-2-42c3704ea155c9761dd27126ef8884a3bebe9522.tar.gz
gentoo-2-42c3704ea155c9761dd27126ef8884a3bebe9522.tar.bz2
gentoo-2-42c3704ea155c9761dd27126ef8884a3bebe9522.zip
Fix flags; thanks to Arfrever Frehtes Taifersar Arahesis. (bug #210506)
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/obpager/ChangeLog8
-rw-r--r--x11-misc/obpager/files/obpager-1.8-as-needed.patch22
-rw-r--r--x11-misc/obpager/obpager-1.8.ebuild8
3 files changed, 34 insertions, 4 deletions
diff --git a/x11-misc/obpager/ChangeLog b/x11-misc/obpager/ChangeLog
index 89e60315b512..f51f9f25fe6b 100644
--- a/x11-misc/obpager/ChangeLog
+++ b/x11-misc/obpager/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/obpager
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/obpager/ChangeLog,v 1.9 2007/11/27 21:21:50 angelos Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/obpager/ChangeLog,v 1.10 2008/02/18 00:29:58 omp Exp $
+
+ 18 Feb 2008; David Shakaryan <omp@gentoo.org>
+ +files/obpager-1.8-as-needed.patch, obpager-1.8.ebuild:
+ Fix flags; thanks to Arfrever Frehtes Taifersar Arahesis. (bug #210506)
27 Nov 2007; Christoph Mende <angelos@gentoo.org> obpager-1.8.ebuild:
Added ~amd64
diff --git a/x11-misc/obpager/files/obpager-1.8-as-needed.patch b/x11-misc/obpager/files/obpager-1.8-as-needed.patch
new file mode 100644
index 000000000000..e8399b357177
--- /dev/null
+++ b/x11-misc/obpager/files/obpager-1.8-as-needed.patch
@@ -0,0 +1,22 @@
+--- Makefile
++++ Makefile
+@@ -16,8 +16,8 @@
+ CPPFLAGS = -ggdb -Wall
+ #CPPFLAGS = -ggdb -Wall -O2
+ INCLUDES = -I/usr/X11R6/include/X11 -I/usr/X11R6/include/X11/extensions -I./src
+-COMPILE = $(CXX) $(CDEFS) $(INCLUDES) $(CPPFLAGS)
+-LINK = $(CXX) $(LDFLAGS) $(LDLIBS)
++COMPILE = $(CXX) $(CDEFS) $(INCLUDES) $(CPPFLAGS) $(CXXFLAGS)
++LINK = $(CXX) $(LDFLAGS)
+ LDLIBS = -L/usr/X11R6/lib -lX11 -lXext
+
+
+@@ -46,7 +46,7 @@
+
+ $(EXECUTABLE): $(OBJS)
+ @echo "Linking "$@ ;\
+- $(LINK) -o $(EXECUTABLE) $(OBJS)
++ $(LINK) -o $(EXECUTABLE) $(OBJS) $(LDLIBS)
+
+ install:
+ @echo "Installing obpager...." ;\
diff --git a/x11-misc/obpager/obpager-1.8.ebuild b/x11-misc/obpager/obpager-1.8.ebuild
index 2d71999f49f7..6effa53456e0 100644
--- a/x11-misc/obpager/obpager-1.8.ebuild
+++ b/x11-misc/obpager/obpager-1.8.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/obpager/obpager-1.8.ebuild,v 1.10 2007/11/27 21:21:50 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/obpager/obpager-1.8.ebuild,v 1.11 2008/02/18 00:29:58 omp Exp $
+
+inherit eutils
DESCRIPTION="Lightweight pager designed to be used with NetWM-compliant window manager"
HOMEPAGE="http://obpager.sourceforge.net/"
@@ -21,6 +23,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+
# this makes it compile :-)
sed -i -e '18s/^.*$/#include <errno.h>/' src/main.cc
sed -i -e 's,X11R6/,,g' Makefile