summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-10-05 23:16:43 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-10-05 23:16:43 +0000
commit4a0c0592cc663fe69bed0ea048e901b3128434a8 (patch)
treec634eb9678f6c6be623a3c8967ac9036ed33044f /x11-misc
parentExtend patch to actually build with glibc 2.8. Closes bug #239611. (diff)
downloadgentoo-2-4a0c0592cc663fe69bed0ea048e901b3128434a8.tar.gz
gentoo-2-4a0c0592cc663fe69bed0ea048e901b3128434a8.tar.bz2
gentoo-2-4a0c0592cc663fe69bed0ea048e901b3128434a8.zip
Patch from Ubuntu to fix IndexError, bug #239169 by W. Elschner
(Portage version: 2.2_rc11/cvs/Linux 2.6.26.5 x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/revelation/ChangeLog8
-rw-r--r--x11-misc/revelation/files/revelation-0.4.11-list-index.patch14
-rw-r--r--x11-misc/revelation/revelation-0.4.11-r1.ebuild47
3 files changed, 68 insertions, 1 deletions
diff --git a/x11-misc/revelation/ChangeLog b/x11-misc/revelation/ChangeLog
index 75cb421ca8b7..a0f2bf85abb9 100644
--- a/x11-misc/revelation/ChangeLog
+++ b/x11-misc/revelation/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/revelation
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/ChangeLog,v 1.10 2008/05/29 18:20:23 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/ChangeLog,v 1.11 2008/10/05 23:16:42 nyhm Exp $
+
+*revelation-0.4.11-r1 (05 Oct 2008)
+
+ 05 Oct 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/revelation-0.4.11-list-index.patch, +revelation-0.4.11-r1.ebuild:
+ Patch from Ubuntu to fix IndexError, bug #239169 by W. Elschner
29 May 2008; Ali Polatel <hawking@gentoo.org> revelation-0.4.11.ebuild:
python_mod_optimize is ROOT aware.
diff --git a/x11-misc/revelation/files/revelation-0.4.11-list-index.patch b/x11-misc/revelation/files/revelation-0.4.11-list-index.patch
new file mode 100644
index 000000000000..efbbc0af2dad
--- /dev/null
+++ b/x11-misc/revelation/files/revelation-0.4.11-list-index.patch
@@ -0,0 +1,14 @@
+--- src/lib/ui.py.orig 2008-10-04 14:23:30.000000000 +0200
++++ src/lib/ui.py 2008-10-04 14:23:46.000000000 +0200
+@@ -1257,8 +1257,9 @@
+ def __init__(self, stock, text = None):
+ gtk.ImageMenuItem.__init__(self, stock)
+
+- self.label = self.get_children()[0]
+- self.image = self.get_children()[1]
++ children=self.get_children()
++ if len(children) > 0 : self.label = children[0]
++ if len(children) > 1 : self.image = children[1]
+
+ if text is not None:
+ self.set_text(text)
diff --git a/x11-misc/revelation/revelation-0.4.11-r1.ebuild b/x11-misc/revelation/revelation-0.4.11-r1.ebuild
new file mode 100644
index 000000000000..a979fb39d375
--- /dev/null
+++ b/x11-misc/revelation/revelation-0.4.11-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/revelation-0.4.11-r1.ebuild,v 1.1 2008/10/05 23:16:42 nyhm Exp $
+
+inherit eutils multilib python gnome2
+
+DESCRIPTION="A password manager for GNOME"
+HOMEPAGE="http://oss.codepoet.no/revelation/"
+SRC_URI="ftp://oss.codepoet.no/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygtk
+ dev-python/pycrypto
+ dev-python/gnome-applets-python
+ dev-python/gnome-python
+ dev-python/gnome-python-extras
+ sys-libs/cracklib"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_unpack() {
+ gnome2_src_unpack
+ ln -sf $(type -P true) py-compile
+ epatch "${FILESDIR}"/${P}-list-index.patch
+}
+
+src_compile() {
+ gnome2_src_compile \
+ --disable-dependency-tracking \
+ --disable-desktop-update \
+ --disable-mime-update
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup
+}