summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-01-08 19:13:48 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2015-01-08 19:13:48 +0000
commit53361a232989166ad60f84542d2dce046360efc1 (patch)
treea24bf5ce0063e154be0bceb27360b681edb54484 /x11-misc
parentVersion bumps (diff)
downloadgentoo-2-53361a232989166ad60f84542d2dce046360efc1.tar.gz
gentoo-2-53361a232989166ad60f84542d2dce046360efc1.tar.bz2
gentoo-2-53361a232989166ad60f84542d2dce046360efc1.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/shutter/ChangeLog9
-rw-r--r--x11-misc/shutter/shutter-0.93.1.ebuild70
2 files changed, 77 insertions, 2 deletions
diff --git a/x11-misc/shutter/ChangeLog b/x11-misc/shutter/ChangeLog
index baee1fd4feea..7d98980976e5 100644
--- a/x11-misc/shutter/ChangeLog
+++ b/x11-misc/shutter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/shutter
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/shutter/ChangeLog,v 1.40 2014/09/07 19:33:40 hwoarang Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/shutter/ChangeLog,v 1.41 2015/01/08 19:13:48 hwoarang Exp $
+
+*shutter-0.93.1 (08 Jan 2015)
+
+ 08 Jan 2015; Markos Chandras <hwoarang@gentoo.org> +shutter-0.93.1.ebuild:
+ Version bump
*shutter-0.93 (07 Sep 2014)
diff --git a/x11-misc/shutter/shutter-0.93.1.ebuild b/x11-misc/shutter/shutter-0.93.1.ebuild
new file mode 100644
index 000000000000..575c90ac0059
--- /dev/null
+++ b/x11-misc/shutter/shutter-0.93.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/shutter/shutter-0.93.1.ebuild,v 1.1 2015/01/08 19:13:48 hwoarang Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Feature-rich screenshot program"
+HOMEPAGE="http://shutter-project.org/"
+SRC_URI="http://shutter-project.org/wp-content/uploads/releases/tars/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="drawing webphoto"
+
+RDEPEND="dev-lang/perl
+ drawing? ( dev-perl/Goo-Canvas )
+ webphoto? ( gnome-extra/gnome-web-photo )
+ || ( media-gfx/imagemagick[perl] media-gfx/graphicsmagick[imagemagick,perl] )
+ dev-perl/libxml-perl
+ dev-perl/gnome2-wnck
+ dev-perl/gnome2-canvas
+ dev-perl/gnome2-perl
+ dev-perl/Gtk2-Unique
+ dev-perl/Gtk2-ImageView
+ dev-perl/File-DesktopEntry
+ dev-perl/File-HomeDir
+ dev-perl/File-Which
+ dev-perl/JSON
+ dev-perl/File-Copy-Recursive
+ dev-perl/File-MimeInfo
+ dev-perl/Locale-gettext
+ dev-perl/Net-DBus
+ dev-perl/Proc-Simple
+ dev-perl/Proc-ProcessTable
+ dev-perl/Sort-Naturally
+ dev-perl/WWW-Mechanize
+ dev-perl/X11-Protocol
+ dev-perl/XML-Simple
+ dev-perl/libwww-perl"
+
+src_prepare() {
+ use webphoto || epatch "${FILESDIR}"/${PN}-0.90-webphoto.patch
+ use drawing || epatch "${FILESDIR}"/${PN}-0.90-goocanvas.patch
+ #Fix tray icon because it doesn't pick the right icon using various themes
+ sed -i -e "/\$tray->set_from_icon_name/s:set_from_icon_name:set_from_file:" \
+ -e "s:shutter-panel:/usr/share/icons/hicolor/scalable/apps/&.svg:" \
+ bin/shutter || die "failed to fix trayicon"
+}
+
+src_install() {
+ dobin bin/${PN} || die "dobin failed"
+ insinto /usr/share/${PN}
+ doins -r share/${PN}/* || die "doins failed"
+ dodoc README || die "dodoc failed"
+ domenu share/applications/${PN}.desktop
+ # Man page is broken. Reconstruct it.
+ gunzip share/man/man1/${PN}.1.gz || die "gunzip failed"
+ doman share/man/man1/${PN}.1 || die "doman failed"
+ doicon share/pixmaps/${PN}.png
+ doins -r share/locale || die "doins failed"
+ insinto /usr/share/icons/hicolor
+ doins -r share/icons/hicolor/* || die "doins failed"
+ find "${D}"/usr/share/shutter/resources/system/plugins/ -type f ! -name '*.*' -exec chmod 755 {} \; \
+ || die "failed to make plugins executables"
+ find "${D}"/usr/share/shutter/resources/system/upload_plugins/upload -type f \
+ -name "*.pm" -exec chmod 755 {} \; || die "failed to make upload plugins executables"
+}