summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-11-08 17:49:48 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2014-11-08 17:49:48 +0000
commit69499cf7ffb87897b7ce4e650b272f95000339ad (patch)
treeabc29d44ac366fdfa53fdb362b1ced0dcc7dd7eb /x11-misc
parentversion bump (diff)
downloadgentoo-2-69499cf7ffb87897b7ce4e650b272f95000339ad.tar.gz
gentoo-2-69499cf7ffb87897b7ce4e650b272f95000339ad.tar.bz2
gentoo-2-69499cf7ffb87897b7ce4e650b272f95000339ad.zip
version bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0xB2EFA1D4)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/obconf-qt/ChangeLog8
-rw-r--r--x11-misc/obconf-qt/obconf-qt-0.1.0_p20141029.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-misc/obconf-qt/ChangeLog b/x11-misc/obconf-qt/ChangeLog
index fdf41e6b24e7..312b8b531a41 100644
--- a/x11-misc/obconf-qt/ChangeLog
+++ b/x11-misc/obconf-qt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/obconf-qt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/obconf-qt/ChangeLog,v 1.2 2014/05/29 07:52:44 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/obconf-qt/ChangeLog,v 1.3 2014/11/08 17:49:48 jauhien Exp $
+
+*obconf-qt-0.1.0_p20141029 (08 Nov 2014)
+
+ 08 Nov 2014; Jauhien Piatlicki <jauhien@gentoo.org>
+ +obconf-qt-0.1.0_p20141029.ebuild:
+ version bump
29 May 2014; Manuel Rüger <mrueg@gentoo.org> obconf-qt-0.1.0.ebuild:
Add ~arm keyword.
diff --git a/x11-misc/obconf-qt/obconf-qt-0.1.0_p20141029.ebuild b/x11-misc/obconf-qt/obconf-qt-0.1.0_p20141029.ebuild
new file mode 100644
index 000000000000..431d57343ea9
--- /dev/null
+++ b/x11-misc/obconf-qt/obconf-qt-0.1.0_p20141029.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/obconf-qt/obconf-qt-0.1.0_p20141029.ebuild,v 1.1 2014/11/08 17:49:48 jauhien Exp $
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Openbox window manager configuration tool"
+HOMEPAGE="http://www.lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://dev.gentoo.org/~jauhien/distfiles/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libxml2
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-wm/openbox:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ )
+ cmake-utils_src_configure
+}