summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2007-01-17 18:48:34 +0000
committerCédric Krier <cedk@gentoo.org>2007-01-17 18:48:34 +0000
commit78f41acd5ec8a30e966e699026e25c1c52bebd41 (patch)
treef4d1b1ba1c701d6b9c397056c2ee5f59e41c26fb /x11-misc
parentTarball was refreshed, regenerate digest. (diff)
downloadgentoo-2-78f41acd5ec8a30e966e699026e25c1c52bebd41.tar.gz
gentoo-2-78f41acd5ec8a30e966e699026e25c1c52bebd41.tar.bz2
gentoo-2-78f41acd5ec8a30e966e699026e25c1c52bebd41.zip
Version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/dmenu/ChangeLog7
-rw-r--r--x11-misc/dmenu/dmenu-2.1.ebuild80
-rw-r--r--x11-misc/dmenu/files/digest-dmenu-2.13
3 files changed, 89 insertions, 1 deletions
diff --git a/x11-misc/dmenu/ChangeLog b/x11-misc/dmenu/ChangeLog
index a2f7025d8c25..4331492ddafa 100644
--- a/x11-misc/dmenu/ChangeLog
+++ b/x11-misc/dmenu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/dmenu
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.5 2007/01/16 19:32:47 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.6 2007/01/17 18:48:34 cedk Exp $
+
+*dmenu-2.1 (17 Jan 2007)
+
+ 17 Jan 2007; Cedric Krier <cedk@gentoo.org> +dmenu-2.1.ebuild:
+ Version bump
*dmenu-2.0 (16 Jan 2007)
diff --git a/x11-misc/dmenu/dmenu-2.1.ebuild b/x11-misc/dmenu/dmenu-2.1.ebuild
new file mode 100644
index 000000000000..1af0a8e44418
--- /dev/null
+++ b/x11-misc/dmenu/dmenu-2.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/dmenu-2.1.ebuild,v 1.1 2007/01/17 18:48:34 cedk Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
+HOMEPAGE="http://suckless.org/view/dynamic+window+manager"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="savedconfig"
+
+DEPEND="x11-libs/libX11"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/.*strip.*//" \
+ Makefile || die "sed failed"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS +=/" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ local conf root
+ for conf in ${PF} ${P} ${PN}; do
+ for root in "${PORTAGE_CONFIGROOT}" "${ROOT}" /; do
+ configfile=${root}etc/portage/savedconfig/${conf}.config.h
+ if [[ -r ${configfile} ]]; then
+ elog "Found your ${configfile} and using it."
+ cp -f ${configfile} "${S}"/${PN}.h
+ return 0
+ fi
+ done
+ done
+ ewarn "Could not locate user configfile, so we will save a default one."
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins ${PN}.h ${PF}.config.h
+
+ dodoc README
+}
+
+pkg_preinst() {
+ if use savedconfig; then
+ mv "${D}"/usr/share/${PN}/${PF}.config.h "${T}"/
+ fi
+}
+
+pkg_postinst() {
+ if use savedconfig; then
+ local config_dir="${PORTAGE_CONFIGROOT:-${ROOT}}/etc/portage/savedconfig"
+ elog "Saving this build config to ${config_dir}/${PF}.config.h"
+ einfo "Read this ebuild for more info on how to take advantage of this option."
+ mkdir -p "${config_dir}"
+ cp "${T}"/${PF}.config.h "${config_dir}"/${PF}.config.h
+ fi
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+}
diff --git a/x11-misc/dmenu/files/digest-dmenu-2.1 b/x11-misc/dmenu/files/digest-dmenu-2.1
new file mode 100644
index 000000000000..da188fe172ea
--- /dev/null
+++ b/x11-misc/dmenu/files/digest-dmenu-2.1
@@ -0,0 +1,3 @@
+MD5 a343d90d2121b1723cdcbfbbaf296b82 dmenu-2.1.tar.gz 7975
+RMD160 ba8ec53d9084e921a525ba3c9595ceadb0f8c297 dmenu-2.1.tar.gz 7975
+SHA256 241ff05f9a1432ae93021060f48e76dfd4aaf138f4c969c695f4c057e7df3c09 dmenu-2.1.tar.gz 7975