summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-30 08:48:09 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-30 08:48:09 +0000
commit7a92277092f0b76593346c8da86f0d88341fb1d3 (patch)
tree64118cb83083406a96731ef311c70c864002e58c /x11-misc
parentebuild missing some patches. (diff)
downloadgentoo-2-7a92277092f0b76593346c8da86f0d88341fb1d3.tar.gz
gentoo-2-7a92277092f0b76593346c8da86f0d88341fb1d3.tar.bz2
gentoo-2-7a92277092f0b76593346c8da86f0d88341fb1d3.zip
Version bump
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/keytouch/ChangeLog7
-rw-r--r--x11-misc/keytouch/files/digest-keytouch-2.2.39
-rw-r--r--x11-misc/keytouch/keytouch-2.2.3.ebuild79
3 files changed, 94 insertions, 1 deletions
diff --git a/x11-misc/keytouch/ChangeLog b/x11-misc/keytouch/ChangeLog
index 54b3b4ff95dc..724ea219d5f7 100644
--- a/x11-misc/keytouch/ChangeLog
+++ b/x11-misc/keytouch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/keytouch
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/keytouch/ChangeLog,v 1.1 2006/10/06 13:19:11 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/keytouch/ChangeLog,v 1.2 2006/10/30 08:48:09 nyhm Exp $
+
+*keytouch-2.2.3 (30 Oct 2006)
+
+ 30 Oct 2006; Tristan Heaven <nyhm@gentoo.org> +keytouch-2.2.3.ebuild:
+ Version bump
*keytouch-2.2.2 (06 Oct 2006)
diff --git a/x11-misc/keytouch/files/digest-keytouch-2.2.3 b/x11-misc/keytouch/files/digest-keytouch-2.2.3
new file mode 100644
index 000000000000..0a8c98e3682a
--- /dev/null
+++ b/x11-misc/keytouch/files/digest-keytouch-2.2.3
@@ -0,0 +1,9 @@
+MD5 a927d5c84a71f02e2b0b0eb1edfdbee6 keytouch-2.2-user_manual.pdf 301051
+RMD160 1a1b228012956be00727c6a11062976d79cac45d keytouch-2.2-user_manual.pdf 301051
+SHA256 d8913c84437bac66adb0464e673bf06ab390042f75603ddf99167758577ed60c keytouch-2.2-user_manual.pdf 301051
+MD5 043b47542608cd7c7be1bbbea82dcad7 keytouch-2.2.3.tar.gz 791226
+RMD160 53539ba421901b19abda14cda8850ccd04a9427a keytouch-2.2.3.tar.gz 791226
+SHA256 e3674cc57c574b2faae014ef630ca69dc042a404ead5cac8edc578fabfeffa5b keytouch-2.2.3.tar.gz 791226
+MD5 366337c740a458ecb323f454bd56307d keytouch-2.2_tech_manual.pdf 244176
+RMD160 d35f36e83c4cf24c0cee3510d639f55a83580766 keytouch-2.2_tech_manual.pdf 244176
+SHA256 921df5388c7aee8dcc9233784a81885fd77f948791f38cd3900a5875df6d3a6f keytouch-2.2_tech_manual.pdf 244176
diff --git a/x11-misc/keytouch/keytouch-2.2.3.ebuild b/x11-misc/keytouch/keytouch-2.2.3.ebuild
new file mode 100644
index 000000000000..d96c6ea069b0
--- /dev/null
+++ b/x11-misc/keytouch/keytouch-2.2.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/keytouch/keytouch-2.2.3.ebuild,v 1.1 2006/10/30 08:48:09 nyhm Exp $
+
+inherit eutils versionator
+
+DOC_V=$(get_version_component_range -2)
+DESCRIPTION="Easily configure extra keyboard function keys"
+HOMEPAGE="http://keytouch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? ( mirror://sourceforge/${PN}/${PN}-${DOC_V}_tech_manual.pdf
+ mirror://sourceforge/${PN}/${PN}-${DOC_V}-user_manual.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc kde"
+
+RDEPEND=">=x11-libs/gtk+-2
+ >=gnome-base/gnome-menus-2.12
+ x11-misc/xbindkeys
+ kde? ( || (
+ kde-base/kdesu
+ kde-base/kdebase ) )
+ !kde? ( x11-libs/gksu )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i 's/install-data-local//1' \
+ keytouch{-acpid,d,-init}/Makefile.in \
+ || die "sed failed"
+
+ sed -i 's/gnome-calculator/gcalctool/' \
+ keyboards/* || die "sed failed"
+}
+
+src_compile() {
+ local d
+ for d in . keytouch-config keytouch-keyboard ; do
+ cd "${S}"/${d}
+ econf || die
+ emake || die "emake ${d} failed"
+ done
+}
+
+src_install() {
+ doinitd "${FILESDIR}"/${PN} || die "doinitd failed"
+
+ newicon keytouch-keyboard/pixmaps/icon.png ${PN}.png
+ make_desktop_entry ${PN} keyTouch ${PN}.png System
+
+ dodoc AUTHORS ChangeLog
+ use doc && dodoc "${DISTDIR}"/*.pdf
+
+ local d
+ for d in . keytouch-config keytouch-keyboard ; do
+ emake -C ${d} DESTDIR="${D}" install \
+ || die "emake install ${d} failed"
+ done
+}
+
+pkg_postinst() {
+ echo
+ elog "To use keyTouch, add \"keytouchd &\" to your"
+ elog "X startup programs and run"
+ elog "\"rc-update add keytouch default\""
+ elog
+ elog "If support for your keyboard is not included in"
+ elog "this release, check for new keyboard files at"
+ elog "http://keytouch.sourceforge.net/dl-keyboards.html"
+# elog
+# elog "x11-misc/keytouch-editor can be used to create"
+# elog "your own keyboard files"
+ echo
+}