summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-29 08:20:17 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-29 08:20:17 +0000
commit8f72d02b4728af7e6c0da441612354ea85f38b55 (patch)
tree3e853fdd9f5ed51ed2dd2577997cc9b479f6a539 /x11-misc
parentRemove old bogus ebuild (diff)
downloadgentoo-2-8f72d02b4728af7e6c0da441612354ea85f38b55.tar.gz
gentoo-2-8f72d02b4728af7e6c0da441612354ea85f38b55.tar.bz2
gentoo-2-8f72d02b4728af7e6c0da441612354ea85f38b55.zip
Moved from sunrise overlay. Bug #242830. Thanks to Christian Ruppert (idl0r) for the ebuild
(Portage version: 2.2_rc71/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/bmpanel/ChangeLog11
-rw-r--r--x11-misc/bmpanel/bmpanel-0.9.27-r1.ebuild47
-rw-r--r--x11-misc/bmpanel/files/Makefile.patch14
-rw-r--r--x11-misc/bmpanel/metadata.xml13
4 files changed, 85 insertions, 0 deletions
diff --git a/x11-misc/bmpanel/ChangeLog b/x11-misc/bmpanel/ChangeLog
new file mode 100644
index 000000000000..294be624c8e1
--- /dev/null
+++ b/x11-misc/bmpanel/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-misc/bmpanel
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bmpanel/ChangeLog,v 1.1 2010/08/29 08:20:17 hwoarang Exp $
+
+*bmpanel-0.9.27-r1 (29 Aug 2010)
+
+ 29 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+ +bmpanel-0.9.27-r1.ebuild, +files/Makefile.patch, +metadata.xml:
+ Moved from sunrise overlay. Bug #242830. Thanks to Christian Ruppert
+ (idl0r) for the ebuild
+
diff --git a/x11-misc/bmpanel/bmpanel-0.9.27-r1.ebuild b/x11-misc/bmpanel/bmpanel-0.9.27-r1.ebuild
new file mode 100644
index 000000000000..43c21df147e6
--- /dev/null
+++ b/x11-misc/bmpanel/bmpanel-0.9.27-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bmpanel/bmpanel-0.9.27-r1.ebuild,v 1.1 2010/08/29 08:20:17 hwoarang Exp $
+
+EAPI=2
+
+inherit base eutils
+
+DESCRIPTION="a lightweight, NETWM compliant panel for X11 Window System."
+HOMEPAGE="http://nsf.110mb.com/bmpanel"
+SRC_URI="http://nsf.110mb.com/${PN}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc"
+IUSE="debug libev libevent"
+
+RDEPEND=">=media-libs/imlib2-1.4.0
+ media-libs/freetype:2
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXcomposite
+ x11-libs/libXfixes
+ media-libs/fontconfig
+ libev? ( dev-libs/libev )
+ libevent? ( dev-libs/libevent )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/Makefile.patch"
+)
+
+DOCS=( AUTHORS README )
+
+src_configure() {
+ # the provided configure script is broken.
+ # it doesn't provide --disable-foo, --host etc. so we can't use econf here.
+ local myconf="--prefix=/usr --ugly"
+
+ use debug && myconf="${myconf} --debug"
+ use libev && myconf="${myconf} --with-ev"
+ use libevent && myconf="${myconf} --with-event"
+
+ einfo "./configure ${myconf}"
+ ./configure ${myconf} || die "configure failed"
+}
diff --git a/x11-misc/bmpanel/files/Makefile.patch b/x11-misc/bmpanel/files/Makefile.patch
new file mode 100644
index 000000000000..d9cdc8308837
--- /dev/null
+++ b/x11-misc/bmpanel/files/Makefile.patch
@@ -0,0 +1,14 @@
+--- src/Makefile.old 2009-02-15 16:12:16.750885874 +0100
++++ src/Makefile 2009-02-15 16:16:24.560106442 +0100
+@@ -12,10 +12,7 @@ ifneq ($(UGLY),1)
+ endif
+
+ $(APP): $(OBJS)
+- $(V_L)$(LD) $(LIBS) -o $@ $(OBJS)
+-ifeq ($(DEBUG),0)
+- $(V_S)strip -s $(APP)
+-endif
++ $(V_L)$(LD) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
+ $(BUILDDIR)/src/%.o: src/%.c .mk/config.mk
+ $(V_C)$(CC) -c -MMD $(CFLAGS) $< -o $@
diff --git a/x11-misc/bmpanel/metadata.xml b/x11-misc/bmpanel/metadata.xml
new file mode 100644
index 000000000000..2d28fb4057be
--- /dev/null
+++ b/x11-misc/bmpanel/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <use>
+ <flag name='libev'>Use the libev event loop interface</flag>
+ <flag name='libevent'>Use the libevent event loop interface</flag>
+ </use>
+</pkgmetadata>