summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-09-03 07:47:38 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-09-03 07:47:38 +0000
commitacea84a21e5ef40f32aed4653f98b78d42fe0e3a (patch)
tree1806c529fdb6f830dede558dc18884f937f28fde /x11-misc
parentUpdated dependencies: works with net-libs/libupnp-1.6 only and boost is build... (diff)
downloadgentoo-2-acea84a21e5ef40f32aed4653f98b78d42fe0e3a.tar.gz
gentoo-2-acea84a21e5ef40f32aed4653f98b78d42fe0e3a.tar.bz2
gentoo-2-acea84a21e5ef40f32aed4653f98b78d42fe0e3a.zip
Respect CC,CFLAGS,LDFLAGS wrt bug 334969. Thanks to Diego for the report. Fix implicit funcions declarations. Fix SIGSEGV on amd64. Keyword ~amd64
(Portage version: 2.2_rc73/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xfishtank/ChangeLog11
-rw-r--r--x11-misc/xfishtank/files/xfishtank-2.1-implicits.patch75
-rw-r--r--x11-misc/xfishtank/xfishtank-2.1-r1.ebuild42
3 files changed, 126 insertions, 2 deletions
diff --git a/x11-misc/xfishtank/ChangeLog b/x11-misc/xfishtank/ChangeLog
index 1ab89f976144..5f8f1c1206d3 100644
--- a/x11-misc/xfishtank/ChangeLog
+++ b/x11-misc/xfishtank/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/xfishtank
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfishtank/ChangeLog,v 1.14 2009/05/04 09:16:05 nelchael Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfishtank/ChangeLog,v 1.15 2010/09/03 07:47:38 xarthisius Exp $
+
+*xfishtank-2.1-r1 (03 Sep 2010)
+
+ 03 Sep 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ +xfishtank-2.1-r1.ebuild, +files/xfishtank-2.1-implicits.patch:
+ Respect CC,CFLAGS,LDFLAGS wrt bug 334969. Thanks to Diego for the report.
+ Fix implicit funcions declarations. Fix SIGSEGV on amd64. Keyword ~amd64
04 May 2009; Krzysiek Pawlik <nelchael@gentoo.org> xfishtank-2.1.ebuild:
Do not strip binaries during install.
diff --git a/x11-misc/xfishtank/files/xfishtank-2.1-implicits.patch b/x11-misc/xfishtank/files/xfishtank-2.1-implicits.patch
new file mode 100644
index 000000000000..0a4a03503246
--- /dev/null
+++ b/x11-misc/xfishtank/files/xfishtank-2.1-implicits.patch
@@ -0,0 +1,75 @@
+--- xfishtank-2.1tp/read.c
++++ xfishtank-2.1tp/read.c
+@@ -1,5 +1,7 @@
+ #include <X11/Xlib.h>
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include "compact.h"
+ #include "medcut.h"
+
+--- xfishtank-2.1tp/medcut.c
++++ xfishtank-2.1tp/medcut.c
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "medcut.h"
+
+ #define RED 0
+--- xfishtank-2.1tp/xfish.c
++++ xfishtank-2.1tp/xfish.c
+@@ -46,6 +46,9 @@
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
++#include <unistd.h>
+ #ifdef sgi
+ #define _BSD_SIGNALS
+ #endif
+@@ -848,8 +850,8 @@
+ struct colr_data colrs[256];
+
+ colormap = XDefaultColormap(Dpy, screen);
+
+- if (colormap == NULL)
++ if (colormap == 0)
+ {
+ return;
+ }
+@@ -1812,9 +1814,11 @@
+ high_res_sleep(seconds)
+ double seconds;
+ {
+- int fds = 0;
++ fd_set fds;
+ struct timeval timeout;
+
++ FD_ZERO(&fds);
++
+ timeout.tv_sec = seconds;
+ timeout.tv_usec = (seconds - timeout.tv_sec) * 1000000.0;
+ select(0, &fds, &fds, &fds, &timeout);
+--- xfishtank-2.1tp/makeh.c
++++ xfishtank-2.1tp/makeh.c
+@@ -1,6 +1,6 @@
+-
++#include <stdlib.h>
+ #include <stdio.h>
+-
++#include <string.h>
+ main()
+ {
+ FILE *fp;
+--- xfishtank-2.1tp/gifread.c
++++ xfishtank-2.1tp/gifread.c
+@@ -56,6 +56,8 @@
+
+ #include <X11/Xlib.h>
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #if defined(SYSV) || defined(SVR4)
+ #include <string.h>
+ #else /* SYSV */
diff --git a/x11-misc/xfishtank/xfishtank-2.1-r1.ebuild b/x11-misc/xfishtank/xfishtank-2.1-r1.ebuild
new file mode 100644
index 000000000000..01fd40b10507
--- /dev/null
+++ b/x11-misc/xfishtank/xfishtank-2.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfishtank/xfishtank-2.1-r1.ebuild,v 1.1 2010/09/03 07:47:38 xarthisius Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+MY_P=${P}tp
+
+DESCRIPTION="Turns your root window into an aquarium."
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/X11/demos/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/X11/demos/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-misc/imake"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-implicits.patch
+}
+
+src_compile() {
+ xmkmf || die
+ emake CDEBUGFLAGS="${CFLAGS}" CC="$(tc-getCC)" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" ${PN} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README README.Linux README.TrueColor README.Why.2.1tp || die
+}