summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-01-22 23:17:12 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-01-22 23:17:12 +0000
commitb708c80ee2b592e56b2d2e3e978669d310dfc4cb (patch)
tree9a197938bd496423b02cf48569c9b400a27e5f3b /x11-misc
parentStable on ppc64 (diff)
downloadgentoo-2-b708c80ee2b592e56b2d2e3e978669d310dfc4cb.tar.gz
gentoo-2-b708c80ee2b592e56b2d2e3e978669d310dfc4cb.tar.bz2
gentoo-2-b708c80ee2b592e56b2d2e3e978669d310dfc4cb.zip
Allow an alternate to /tmp to be specified so that imake works if /tmp is
noexec. Thanks to Torsten Veller in #119984. (Portage version: 2.1_pre3-r1)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/imake/ChangeLog9
-rw-r--r--x11-misc/imake/Manifest15
-rw-r--r--x11-misc/imake/files/0128_all_4.2.0-imake-tmpdir-v2.patch37
-rw-r--r--x11-misc/imake/files/digest-imake-1.0.1-r11
-rw-r--r--x11-misc/imake/imake-1.0.1-r1.ebuild17
5 files changed, 67 insertions, 12 deletions
diff --git a/x11-misc/imake/ChangeLog b/x11-misc/imake/ChangeLog
index 501e548a6ec0..8f7d16d11b7b 100644
--- a/x11-misc/imake/ChangeLog
+++ b/x11-misc/imake/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/imake
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/imake/ChangeLog,v 1.13 2006/01/08 19:48:46 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/imake/ChangeLog,v 1.14 2006/01/22 23:17:12 joshuabaergen Exp $
+
+*imake-1.0.1-r1 (22 Jan 2006)
+
+ 22 Jan 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ +files/0128_all_4.2.0-imake-tmpdir-v2.patch, +imake-1.0.1-r1.ebuild:
+ Allow an alternate to /tmp to be specified so that imake works if /tmp is
+ noexec. Thanks to Torsten Veller in #119984.
08 Jan 2006; <nixnut@gentoo.org> imake-1.0.1.ebuild:
Add ~ppc keyword
diff --git a/x11-misc/imake/Manifest b/x11-misc/imake/Manifest
index 13e176a30e15..377d8dca23a4 100644
--- a/x11-misc/imake/Manifest
+++ b/x11-misc/imake/Manifest
@@ -1,14 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 bca4d910fb8e15b526ac0ef38eb21ac7 ChangeLog 1757
+MD5 512d6aeb0e3767948754f9405772dfa2 ChangeLog 2040
+MD5 33601310b3a1040e1d836d1648e84b41 files/0128_all_4.2.0-imake-tmpdir-v2.patch 1062
MD5 255d2b71fe09891de8f4c0a84eee581e files/digest-imake-1.0.1 64
+MD5 255d2b71fe09891de8f4c0a84eee581e files/digest-imake-1.0.1-r1 64
+MD5 eb88a390b4f49e4e0a4e476b77465415 imake-1.0.1-r1.ebuild 561
MD5 c5ba0f778fb1722bd319a28441eaddde imake-1.0.1.ebuild 513
MD5 a37bab73e2f24b213932c30997d3d360 metadata.xml 156
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDwWySoFw4q70f3SsRAg21AJ932GV7LM5Bd9J1qHTyr3bFbEac9wCcD/G8
-BYF2s7ULszy3esQoYFTtONw=
-=1jDE
------END PGP SIGNATURE-----
diff --git a/x11-misc/imake/files/0128_all_4.2.0-imake-tmpdir-v2.patch b/x11-misc/imake/files/0128_all_4.2.0-imake-tmpdir-v2.patch
new file mode 100644
index 000000000000..209cb15bf543
--- /dev/null
+++ b/x11-misc/imake/files/0128_all_4.2.0-imake-tmpdir-v2.patch
@@ -0,0 +1,37 @@
+--- xc/config/imake/imake.c.orig 2001-12-14 20:53:18.000000000 +0100
++++ xc/config/imake/imake.c 2003-09-12 15:00:10.000000000 +0200
+@@ -985,13 +985,23 @@
+ static void
+ get_libc_version(FILE *inFile)
+ {
+- char aout[] = "/tmp/imakeXXXXXX";
++ char aout[4096], *tmpdir;
+ FILE *fp;
+ const char *format = "%s -o %s -x c -";
+ char *cc;
+ int len;
+ char *command;
+
++ /* If $TMPDIR is defined and has an acceptable length,
++ * use that as tmp dir, else use /tmp. That fixes
++ * problems with /tmp mounted "noexec".
++ */
++ if((tmpdir = getenv("TMPDIR")) != NULL && strlen(tmpdir) < (4096-13))
++ strcpy(aout, tmpdir);
++ else
++ strcpy(aout, "/tmp");
++ strcat(aout, "/imakeXXXXXX");
++
+ /* Pre-create temp file safely */
+ {
+ /* Linux + ELF has mkstemp() */
+@@ -1007,7 +1017,8 @@
+ cc = "gcc";
+ len = strlen (aout) + strlen (format) + strlen (cc);
+ if (len < 128) len = 128;
+- command = alloca (len);
++ if((command = alloca (len)) == NULL)
++ abort();
+
+ if (snprintf (command , len, format, cc, aout) == len)
+ abort ();
diff --git a/x11-misc/imake/files/digest-imake-1.0.1-r1 b/x11-misc/imake/files/digest-imake-1.0.1-r1
new file mode 100644
index 000000000000..5dc088a8258f
--- /dev/null
+++ b/x11-misc/imake/files/digest-imake-1.0.1-r1
@@ -0,0 +1 @@
+MD5 8c859fdddd57e91132ceab1344bfe728 imake-1.0.1.tar.bz2 108642
diff --git a/x11-misc/imake/imake-1.0.1-r1.ebuild b/x11-misc/imake/imake-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..2898e5977001
--- /dev/null
+++ b/x11-misc/imake/imake-1.0.1-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/imake/imake-1.0.1-r1.ebuild,v 1.1 2006/01/22 23:17:12 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org imake build system"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+RDEPEND="x11-misc/xorg-cf-files
+ !x11-misc/xmkmf"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+PATCHES="${FILESDIR}/0128_all_4.2.0-imake-tmpdir-v2.patch"