summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-09-03 15:53:08 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-09-03 15:53:08 +0000
commitfa50d678a0fc9aac05854625b00b756bb4668f74 (patch)
tree86a701c0611ac8359d5450c0301fec25f8941b16 /x11-misc
parentStable on alpha wrt security Bug #145706. (diff)
downloadgentoo-2-fa50d678a0fc9aac05854625b00b756bb4668f74.tar.gz
gentoo-2-fa50d678a0fc9aac05854625b00b756bb4668f74.tar.bz2
gentoo-2-fa50d678a0fc9aac05854625b00b756bb4668f74.zip
Make evolvotron compile with gcc4, see bug #146119.
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/evolvotron/ChangeLog6
-rw-r--r--x11-misc/evolvotron/evolvotron-0.3.1.ebuild5
-rw-r--r--x11-misc/evolvotron/files/evolvotron-0.3.1-gcc4.patch33
3 files changed, 41 insertions, 3 deletions
diff --git a/x11-misc/evolvotron/ChangeLog b/x11-misc/evolvotron/ChangeLog
index b4159468424e..0e1a93a12652 100644
--- a/x11-misc/evolvotron/ChangeLog
+++ b/x11-misc/evolvotron/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/evolvotron
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/evolvotron/ChangeLog,v 1.8 2006/02/16 16:39:32 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/evolvotron/ChangeLog,v 1.9 2006/09/03 15:53:07 nelchael Exp $
+
+ 03 Sep 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/evolvotron-0.3.1-gcc4.patch, evolvotron-0.3.1.ebuild:
+ Make evolvotron compile with gcc4, see bug #146119.
16 Feb 2006; Krzysiek Pawlik <nelchael@gentoo.org>
evolvotron-0.3.1.ebuild:
diff --git a/x11-misc/evolvotron/evolvotron-0.3.1.ebuild b/x11-misc/evolvotron/evolvotron-0.3.1.ebuild
index 2ac2b65639af..fbf117844210 100644
--- a/x11-misc/evolvotron/evolvotron-0.3.1.ebuild
+++ b/x11-misc/evolvotron/evolvotron-0.3.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/evolvotron/evolvotron-0.3.1.ebuild,v 1.5 2006/02/16 16:39:32 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/evolvotron/evolvotron-0.3.1.ebuild,v 1.6 2006/09/03 15:53:07 nelchael Exp $
-inherit qt3
+inherit qt3 eutils
DESCRIPTION="An interactive generative art application"
HOMEPAGE="http://www.bottlenose.demon.co.uk/share/evolvotron/index.htm"
@@ -24,6 +24,7 @@ src_unpack() {
-e "/^QMAKE_CXXFLAGS_RELEASE += -O3/ s:=.*:= ${CXXFLAGS}:" \
-e '/^INSTALLPATH/ s:=.*:= /usr/bin:' ${S}/common.pro \
|| die "sed common.pro failed"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
}
src_compile() {
diff --git a/x11-misc/evolvotron/files/evolvotron-0.3.1-gcc4.patch b/x11-misc/evolvotron/files/evolvotron-0.3.1-gcc4.patch
new file mode 100644
index 000000000000..452ccd5dd7c2
--- /dev/null
+++ b/x11-misc/evolvotron/files/evolvotron-0.3.1-gcc4.patch
@@ -0,0 +1,33 @@
+diff -Nru evolvotron.vanilla/libevolvotron/function_node.h evolvotron/libevolvotron/function_node.h
+--- evolvotron.vanilla/libevolvotron/function_node.h 2006-09-03 17:42:30.000000000 +0200
++++ evolvotron/libevolvotron/function_node.h 2006-09-03 17:46:11.000000000 +0200
+@@ -133,7 +133,7 @@
+ static const std::vector<FunctionNode*> stubargs(const MutationParameters& parameters,uint n,bool exciting=false);
+
+ //! Return a suitable starting value for a node's iteration count (assuming it's iterative).
+- static const uint FunctionNode::stubiterations(const MutationParameters& parameters);
++ static const uint stubiterations(const MutationParameters& parameters);
+
+ //! Constructor given an array of params and args and an iteration count.
+ /*! These MUST be provided; there are no alterative constructors.
+diff -Nru evolvotron.vanilla/libevolvotron/mutation_parameters.h evolvotron/libevolvotron/mutation_parameters.h
+--- evolvotron.vanilla/libevolvotron/mutation_parameters.h 2006-09-03 17:42:30.000000000 +0200
++++ evolvotron/libevolvotron/mutation_parameters.h 2006-09-03 17:43:19.000000000 +0200
+@@ -266,7 +266,7 @@
+ //! This returns a new random bit of tree.
+ /*! Setting the "exciting" flag avoids the most basic node types, but only at the top level of the stub tree.
+ */
+- FunctionNode*const MutationParameters::random_function_stub(bool exciting) const;
++ FunctionNode*const random_function_stub(bool exciting) const;
+
+ void change_function_weighting(const FunctionRegistration* fn,float w);
+
+@@ -277,7 +277,7 @@
+ protected:
+
+ //! Return a random function appropriately biased by current settings
+- FunctionNode*const MutationParameters::random_function() const;
++ FunctionNode*const random_function() const;
+
+ //! Return a random function registration, appropriately biased by current settings
+ const FunctionRegistration*const random_weighted_function_registration() const;