summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-06-13 04:03:26 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-06-13 04:03:26 +0000
commitc76e03ea72e9fcf0a936f884ce955dd6f0349c22 (patch)
tree65fb452624de49c06b0e9c57f5960046444c7a24 /x11-plugins/ascpu
parentstable on ppc64, bug #53766 (Manifest recommit) (diff)
downloadgentoo-2-c76e03ea72e9fcf0a936f884ce955dd6f0349c22.tar.gz
gentoo-2-c76e03ea72e9fcf0a936f884ce955dd6f0349c22.tar.bz2
gentoo-2-c76e03ea72e9fcf0a936f884ce955dd6f0349c22.zip
Version bump. Closing bug #51878.
Diffstat (limited to 'x11-plugins/ascpu')
-rw-r--r--x11-plugins/ascpu/ChangeLog8
-rw-r--r--x11-plugins/ascpu/Manifest8
-rw-r--r--x11-plugins/ascpu/ascpu-1.10.ebuild31
-rw-r--r--x11-plugins/ascpu/files/ascpu-1.10-gentoo.patch28
-rw-r--r--x11-plugins/ascpu/files/digest-ascpu-1.101
5 files changed, 72 insertions, 4 deletions
diff --git a/x11-plugins/ascpu/ChangeLog b/x11-plugins/ascpu/ChangeLog
index f09d2c96152a..2587ebc22f9f 100644
--- a/x11-plugins/ascpu/ChangeLog
+++ b/x11-plugins/ascpu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/ascpu
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/ascpu/ChangeLog,v 1.5 2004/03/17 21:48:30 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/ascpu/ChangeLog,v 1.6 2004/06/13 04:03:26 pyrania Exp $
+
+*ascpu-1.10 (13 Jun 2004)
+
+ 13 Jun 2004; <pyrania@gentoo.org> +files/ascpu-1.10-gentoo.patch,
+ +ascpu-1.10.ebuild:
+ Version bump. Closing bug #51878.
17 Mar 2004; Ciaran McCreesh <ciaranm@gentoo.org> ascpu-1.9.ebuild:
Added ~sparc (#44975)
diff --git a/x11-plugins/ascpu/Manifest b/x11-plugins/ascpu/Manifest
index 5b8559035daa..1845023cc9b1 100644
--- a/x11-plugins/ascpu/Manifest
+++ b/x11-plugins/ascpu/Manifest
@@ -1,4 +1,6 @@
-MD5 4d98e83cde3d331ce46b996ca8fc77b7 ChangeLog 571
-MD5 3cc1350310b4e430b02628ec7a81a6d1 ascpu-1.9.ebuild 698
-MD5 d8501577130cd99a4eb4543995c90c2f files/ascpu-1.9-gentoo.patch 763
+MD5 7be1daabb610ba092367f93bfa1a4770 ChangeLog 570
+MD5 64e631712811e074423b7280833979d0 ascpu-1.9.ebuild 697
+MD5 86ca898650b03f66a103f9ef8e5bdb6f ascpu-1.10.ebuild 700
+MD5 a566b5b5a9c4e940161813e32d9673a6 files/digest-ascpu-1.10 61
MD5 683348a20ecc2ea05fc85877e60846a0 files/digest-ascpu-1.9 60
+MD5 d8501577130cd99a4eb4543995c90c2f files/ascpu-1.9-gentoo.patch 763
diff --git a/x11-plugins/ascpu/ascpu-1.10.ebuild b/x11-plugins/ascpu/ascpu-1.10.ebuild
new file mode 100644
index 000000000000..e271a4e30443
--- /dev/null
+++ b/x11-plugins/ascpu/ascpu-1.10.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/ascpu/ascpu-1.10.ebuild,v 1.1 2004/06/13 04:03:26 pyrania Exp $
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="CPU statistics monitor utility for X Windows"
+SRC_URI="http://www.tigr.net/afterstep/download/ascpu/${P}.tar.gz"
+HOMEPAGE="http://www.tigr.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+DEPEND="virtual/x11"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch || die
+}
+
+src_install () {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+
+ make DESTDIR=${D} install || die
+ dodoc README INSTALL LICENSE
+}
diff --git a/x11-plugins/ascpu/files/ascpu-1.10-gentoo.patch b/x11-plugins/ascpu/files/ascpu-1.10-gentoo.patch
new file mode 100644
index 000000000000..674c97465e18
--- /dev/null
+++ b/x11-plugins/ascpu/files/ascpu-1.10-gentoo.patch
@@ -0,0 +1,28 @@
+diff -Naur autoconf_/Makefile.common.in autoconf/Makefile.common.in
+--- autoconf_/Makefile.common.in 2004-06-13 05:56:03.076266616 +0200
++++ autoconf/Makefile.common.in 2004-06-13 05:56:43.281154544 +0200
+@@ -10,10 +10,10 @@
+
+ install.bin: $(PROG)
+ $(STRIP) $(PROG)
+- $(INSTALL_PROGRAM) $(PROG) $(AFTER_BIN_DIR)
++ $(INSTALL_PROGRAM) $(PROG) ${DESTDIR}$(AFTER_BIN_DIR)
+
+ install.man:
+- $(INSTALL_DATA) $(PROG).man $(AFTER_MAN_DIR)/$(PROG).1x
++ $(INSTALL_DATA) $(PROG).man ${DESTDIR}$(AFTER_MAN_DIR)/$(PROG).1x
+
+ uninstall:
+ $(RMF) $(AFTER_BIN_DIR)/$(PROG)
+diff -Naur autoconf_/Makefile.defines.in autoconf/Makefile.defines.in
+--- autoconf_/Makefile.defines.in 2004-06-13 05:56:03.075266768 +0200
++++ autoconf/Makefile.defines.in 2004-06-13 05:57:30.987902016 +0200
+@@ -2,6 +2,8 @@
+ # Copyright (c) 1998, Guylhem AZNAR <guylhem@oeil.qc.ca>
+ #
+
++DESTDIR =
++
+ CC = @CC@
+ CCFLAGS = @CFLAGS@
+ # -march=pentiumpro -mcpu=pentiumpro
diff --git a/x11-plugins/ascpu/files/digest-ascpu-1.10 b/x11-plugins/ascpu/files/digest-ascpu-1.10
new file mode 100644
index 000000000000..424f0a68cc2c
--- /dev/null
+++ b/x11-plugins/ascpu/files/digest-ascpu-1.10
@@ -0,0 +1 @@
+MD5 5194f1e5e199fadd618ff8cf1a8a7a71 ascpu-1.10.tar.gz 43622