summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2004-07-18 04:01:08 +0000
committerMike Gardiner <obz@gentoo.org>2004-07-18 04:01:08 +0000
commit6fc89b6b6cb50084d19f1040f16c95d3d0f47aef (patch)
treedb7a6807904126d33077a97d709152a8c58cc96a /x11-plugins/desklet-rhythmlet
parentManifest fix - files/init.d_ircd size mismatch (Manifest recommit) (diff)
downloadgentoo-2-6fc89b6b6cb50084d19f1040f16c95d3d0f47aef.tar.gz
gentoo-2-6fc89b6b6cb50084d19f1040f16c95d3d0f47aef.tar.bz2
gentoo-2-6fc89b6b6cb50084d19f1040f16c95d3d0f47aef.zip
First version in portage, as requested in bug #55181
Diffstat (limited to 'x11-plugins/desklet-rhythmlet')
-rw-r--r--x11-plugins/desklet-rhythmlet/ChangeLog9
-rw-r--r--x11-plugins/desklet-rhythmlet/Manifest2
-rw-r--r--x11-plugins/desklet-rhythmlet/desklet-rhythmlet-0.3g.ebuild58
-rw-r--r--x11-plugins/desklet-rhythmlet/files/digest-desklet-rhythmlet-0.3g1
-rw-r--r--x11-plugins/desklet-rhythmlet/metadata.xml6
5 files changed, 76 insertions, 0 deletions
diff --git a/x11-plugins/desklet-rhythmlet/ChangeLog b/x11-plugins/desklet-rhythmlet/ChangeLog
new file mode 100644
index 000000000000..494d2d9a453b
--- /dev/null
+++ b/x11-plugins/desklet-rhythmlet/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-plugins/desklet-rhythmlet
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/desklet-rhythmlet/ChangeLog,v 1.1 2004/07/18 04:01:08 obz Exp $
+
+*desklet-rhythmlet-0.3g (18 Jul 2004)
+
+ 18 Jul 2004; Mike Gardiner <obz@gentoo.org> +desklet-rhythmlet-0.3g.ebuild:
+ First version in portage, as requested in bug #55181
+
diff --git a/x11-plugins/desklet-rhythmlet/Manifest b/x11-plugins/desklet-rhythmlet/Manifest
new file mode 100644
index 000000000000..fb37e4d1fbfc
--- /dev/null
+++ b/x11-plugins/desklet-rhythmlet/Manifest
@@ -0,0 +1,2 @@
+MD5 06512b6d453f6846b3f7db2b9e2027c5 desklet-rhythmlet-0.3g.ebuild 1525
+MD5 0ef75251b83f0cae5fbdd4bb9d741dad files/digest-desklet-rhythmlet-0.3g 69
diff --git a/x11-plugins/desklet-rhythmlet/desklet-rhythmlet-0.3g.ebuild b/x11-plugins/desklet-rhythmlet/desklet-rhythmlet-0.3g.ebuild
new file mode 100644
index 000000000000..85e81d7d5c42
--- /dev/null
+++ b/x11-plugins/desklet-rhythmlet/desklet-rhythmlet-0.3g.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/desklet-rhythmlet/desklet-rhythmlet-0.3g.ebuild,v 1.1 2004/07/18 04:01:08 obz Exp $
+
+DESKLET_NAME="Rhythmlet"
+
+MY_PN=${PN/desklet-/}
+MY_P=${MY_PN}-${PV}-r2
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A display for controlling the Rhythmbox music player from gDesklets"
+SRC_URI="http://gdesklets.gnomedesktop.org/files/${MY_P}.tar.gz"
+HOMEPAGE="http://gdesklets.gnomedesktop.org/categories.php?func=gd_show_app&gd_app_id=162"
+LICENSE="as-is"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+
+DEPEND=">=gnome-extra/gdesklets-core-0.26
+ >=x11-plugins/desklet-psisensors-20040420
+ >=dev-python/gnome-python-2.0
+ >=dev-python/soappy-0.11
+ >=dev-python/Imaging-1.0
+ >=media-sound/rhythmbox-0.8.5"
+
+DOCS="ChangeLog INSTALL README"
+
+src_install() {
+
+ SYS_PATH="/usr/share/gdesklets"
+ INSTALL_BIN="Install_${DESKLET_NAME}_Sensor.bin"
+ dodir ${SYS_PATH}/{Sensors,Displays}
+
+ # first we install the Sensor
+ python ${INSTALL_BIN} --nomsg ${D}${SYS_PATH}/Sensors
+
+ # and then the .displays for the normal rhythmlet
+ insinto ${SYS_PATH}/Displays/${DESKLET_NAME}
+ doins *.display
+ # and finally the graphics
+ cp -R gfx/ ${D}${SYS_PATH}/Displays/${DESKLET_NAME}
+
+ # and also the CornerRhythmlet .displays
+ cd CornerRhythmlet
+ insinto ${SYS_PATH}/Displays/${DESKLET_NAME}/CornerRhythmlet
+ doins *.display
+ cp -R gfx/ ${D}${SYS_PATH}/Displays/${DESKLET_NAME}/CornerRhythmlet
+
+ cd ${S}
+ # Install the documentation
+ dodoc ${DOCS}
+
+ # the desklets unpack preserves permissions of the archive
+ chown -R root:root ${D}${SYS_PATH}/Sensors/${DESKLET_NAME}
+
+}
+
diff --git a/x11-plugins/desklet-rhythmlet/files/digest-desklet-rhythmlet-0.3g b/x11-plugins/desklet-rhythmlet/files/digest-desklet-rhythmlet-0.3g
new file mode 100644
index 000000000000..029cfb06e9a0
--- /dev/null
+++ b/x11-plugins/desklet-rhythmlet/files/digest-desklet-rhythmlet-0.3g
@@ -0,0 +1 @@
+MD5 355f2e4349928cd943e69f241c089ad7 rhythmlet-0.3g-r2.tar.gz 326119
diff --git a/x11-plugins/desklet-rhythmlet/metadata.xml b/x11-plugins/desklet-rhythmlet/metadata.xml
new file mode 100644
index 000000000000..d62df026be9a
--- /dev/null
+++ b/x11-plugins/desklet-rhythmlet/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<maintainer><email>obz@gentoo.org</email></maintainer>
+</pkgmetadata>