summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2005-09-08 10:03:47 +0000
committerSimon Stelling <blubb@gentoo.org>2005-09-08 10:03:47 +0000
commit158edf1759c37a58b81a03bcb039dc4de1d8cee4 (patch)
treef959a0869462a434c4c9312c4909f8dabab119a8 /x11-plugins/gaim-latex/gaim-latex-0.3.ebuild
parentmultilib-strict (diff)
downloadgentoo-2-158edf1759c37a58b81a03bcb039dc4de1d8cee4.tar.gz
gentoo-2-158edf1759c37a58b81a03bcb039dc4de1d8cee4.tar.bz2
gentoo-2-158edf1759c37a58b81a03bcb039dc4de1d8cee4.zip
add ~amd64, add -fPIC, make multilib-strict aware: bug 103538
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-plugins/gaim-latex/gaim-latex-0.3.ebuild')
-rw-r--r--x11-plugins/gaim-latex/gaim-latex-0.3.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/x11-plugins/gaim-latex/gaim-latex-0.3.ebuild b/x11-plugins/gaim-latex/gaim-latex-0.3.ebuild
index 7f2aa6ae7ac4..a2b419461cd7 100644
--- a/x11-plugins/gaim-latex/gaim-latex-0.3.ebuild
+++ b/x11-plugins/gaim-latex/gaim-latex-0.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-latex/gaim-latex-0.3.ebuild,v 1.2 2005/06/17 09:53:24 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-latex/gaim-latex-0.3.ebuild,v 1.3 2005/09/08 10:03:47 blubb Exp $
+
+inherit flag-o-matic multilib
DESCRIPTION="Gaim plugin that renders latex formulae"
HOMEPAGE="http://sourceforge.net/projects/gaim-latex"
@@ -8,7 +10,7 @@ SRC_URI="mirror://sourceforge/gaim-latex/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
DEPEND="net-im/gaim"
@@ -17,11 +19,13 @@ RDEPEND="virtual/tetex
src_compile()
{
+ append-flags -fPIC
emake || die "emake failed"
}
src_install()
{
- make install PREFIX=${D}/usr || die "make install failed"
+ make LIB_INSTALL_DIR="${D}/usr/$(get_libdir)" install PREFIX=${D}/usr \
+ || die "make install failed"
dodoc README CHANGELOG COPYING TODO
}