summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2010-08-11 12:45:34 +0000
committerJim Ramsay <lack@gentoo.org>2010-08-11 12:45:34 +0000
commite19441099f7bea280c76ac366bdde420068dc3a8 (patch)
tree7ab19cb3a091a92d5ecd2385b2c92bcd8027fc93 /x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild
parentFix radiant paths for unbundled rails, thanks to Daniel Bahrdt in bug 332119.... (diff)
downloadgentoo-2-e19441099f7bea280c76ac366bdde420068dc3a8.tar.gz
gentoo-2-e19441099f7bea280c76ac366bdde420068dc3a8.tar.bz2
gentoo-2-e19441099f7bea280c76ac366bdde420068dc3a8.zip
Patch to respect LDFLAGS (Bug #331809)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild')
-rw-r--r--x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild b/x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild
new file mode 100644
index 000000000000..f286e609a9bb
--- /dev/null
+++ b/x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild,v 1.1 2010/08/11 12:45:34 lack Exp $
+
+EAPI=3
+inherit gkrellm-plugin
+
+IUSE="+alsa esd nls"
+
+DESCRIPTION="A plugin for GKrellM2 that has a VU meter and a sound chart"
+HOMEPAGE="http://members.dslextreme.com/users/billw/gkrellmss/gkrellmss.html"
+SRC_URI="http://web.wt.net/~billw/gkrellmss/${P}.tar.gz"
+
+RDEPEND="=sci-libs/fftw-3*
+ esd? ( media-sound/esound )
+ alsa? ( media-libs/alsa-lib )"
+
+DEPEND="${RDEPEND}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+PLUGIN_SO="src/gkrellmss.so"
+PLUGIN_DOCS="Themes"
+
+pkg_setup() {
+ if ! use esd && ! use alsa; then
+ die "You must enable at least one of USE=esd or USE=alsa"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Respect-LDFLAGS.patch"
+}
+
+src_compile() {
+ local myconf
+
+ use nls && myconf="${myconf} enable_nls=1"
+
+ addpredict /dev/snd
+ emake ${myconf} || die
+}