summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-06-01 19:09:46 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-06-01 19:09:46 +0000
commit0fce96830d79ba6b500b676b05c9630950c53c31 (patch)
tree89e433a3fdc8f0bdee335d2ec7788469d74955ac /x11-plugins/gkrelltop/gkrelltop-2.2.3.ebuild
parentupdated X-related descriptions to not refer specifically to xfree86 (diff)
downloadgentoo-2-0fce96830d79ba6b500b676b05c9630950c53c31.tar.gz
gentoo-2-0fce96830d79ba6b500b676b05c9630950c53c31.tar.bz2
gentoo-2-0fce96830d79ba6b500b676b05c9630950c53c31.zip
Version bumped. Closes 52226
Diffstat (limited to 'x11-plugins/gkrelltop/gkrelltop-2.2.3.ebuild')
-rw-r--r--x11-plugins/gkrelltop/gkrelltop-2.2.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/gkrelltop/gkrelltop-2.2.3.ebuild b/x11-plugins/gkrelltop/gkrelltop-2.2.3.ebuild
new file mode 100644
index 000000000000..235c19f9bd6e
--- /dev/null
+++ b/x11-plugins/gkrelltop/gkrelltop-2.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/gkrelltop-2.2.3.ebuild,v 1.1 2004/06/01 19:09:46 mholzer Exp $
+
+DESCRIPTION="a GKrellM2 plugin which displays the top three processes"
+SRC_URI="http://psychology.rutgers.edu/~zaimi/html/${PN}/${PN}.${PV}.tgz"
+HOMEPAGE="http://psychology.rutgers.edu/~zaimi/software.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+
+IUSE=""
+
+DEPEND="=app-admin/gkrellm-2*"
+
+src_compile() {
+ # Unfortunately, the supplied Makefile won't work properly on
+ # non-x86, so we have to do this the hard way.
+ CONFIG="-DLINUX -DGKRELLM2 -fPIC `pkg-config gtk+-2.0 --cflags`"
+ LIBS="`pkg-config gtk+-2.0 --libs` -shared"
+ OBJS="top_three2.o gkrelltop2.o"
+ gcc -c $CONFIG $CFLAGS top_three.c -o top_three2.o || die
+ gcc -c $CONFIG $CFLAGS gkrelltop.c -o gkrelltop2.o || die
+ gcc $LIBS $CONFIG $CFLAGS -o gkrelltop2.so $OBJS || die
+}
+
+src_install() {
+ dodoc README
+ insinto /usr/lib/gkrellm2/plugins
+ doins gkrelltop2.so
+}