summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Vasilevski <yvasilev@gentoo.org>2010-01-06 01:24:13 +0000
committerYuri Vasilevski <yvasilev@gentoo.org>2010-01-06 01:24:13 +0000
commit4386b026dfa82229d181dd73d15eeaf15a29c175 (patch)
tree1961fcd4197d37f5be7b5d197055424ff3425d4f /x11-plugins/matchbox-desktop-image-browser/files
parentRemoved old, respect user's CFLAGS (diff)
downloadgentoo-2-4386b026dfa82229d181dd73d15eeaf15a29c175.tar.gz
gentoo-2-4386b026dfa82229d181dd73d15eeaf15a29c175.tar.bz2
gentoo-2-4386b026dfa82229d181dd73d15eeaf15a29c175.zip
Fixed the installation path for the dynamically loadable mb-desktop module. Bug #298871, thanks flameeyes for reporting.
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'x11-plugins/matchbox-desktop-image-browser/files')
-rw-r--r--x11-plugins/matchbox-desktop-image-browser/files/matchbox-desktop-image-browser-0.2-plugin-location-fix.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-plugins/matchbox-desktop-image-browser/files/matchbox-desktop-image-browser-0.2-plugin-location-fix.patch b/x11-plugins/matchbox-desktop-image-browser/files/matchbox-desktop-image-browser-0.2-plugin-location-fix.patch
new file mode 100644
index 000000000000..9026e3c95142
--- /dev/null
+++ b/x11-plugins/matchbox-desktop-image-browser/files/matchbox-desktop-image-browser-0.2-plugin-location-fix.patch
@@ -0,0 +1,36 @@
+diff -Naurp mb-desktop-image-browser-0.2.orig/configure.ac mb-desktop-image-browser-0.2/configure.ac
+--- mb-desktop-image-browser-0.2.orig/configure.ac 2010-01-06 01:05:40.000000000 +0000
++++ mb-desktop-image-browser-0.2/configure.ac 2010-01-06 01:07:24.000000000 +0000
+@@ -34,6 +34,20 @@ AC_ARG_ENABLE(debug,
+ MB_CFLAGS="$MB_CFLAGS -DDEBUG"
+ fi])
+
++
++dnl ------ Substitute in found libs, clags to Makefiles etc -----------------
++
++if test "x$prefix" = xNONE; then
++ prefix="${ac_default_prefix}"
++fi
++if test "x$exec_prefix" = xNONE; then
++ exec_prefix='${prefix}'
++fi
++
++MBDESKTOP_PLUGIN_DIR=$libdir/matchbox/desktop
++eval MBDESKTOP_PLUGIN_DIR=`eval echo "$MBDESKTOP_PLUGIN_DIR"`
++
++AC_SUBST(MBDESKTOP_PLUGIN_DIR)
+ AC_SUBST(MB_LIBS)
+ AC_SUBST(MB_CFLAGS)
+
+diff -Naurp mb-desktop-image-browser-0.2.orig/Makefile.am mb-desktop-image-browser-0.2/Makefile.am
+--- mb-desktop-image-browser-0.2.orig/Makefile.am 2010-01-06 01:05:40.000000000 +0000
++++ mb-desktop-image-browser-0.2/Makefile.am 2010-01-06 01:07:01.000000000 +0000
+@@ -4,7 +4,7 @@ LDADD = $(MB_LIBS)
+ AM_CFLAGS = $(MB_CFLAGS) -g -DDATADIR=\"$(datadir)\"
+
+ lib_LTLIBRARIES = imgbrowser.la
+-libdir = $(datadir)/matchbox/desktop/modules
++libdir = $(MBDESKTOP_PLUGIN_DIR)
+
+ imgbrowser_la_SOURCES = imgbrowser.c
+ imgbrowser_la_LIBADD = $(LDADD)