summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2010-07-21 04:16:03 +0000
committerPatrick McLean <chutzpah@gentoo.org>2010-07-21 04:16:03 +0000
commit95f43c7e7fb69c33eb5e4c3b4fdd190f77bda7c0 (patch)
treefe76b2beaa3e4d02dba2b1c0e284d63728e73572 /x11-plugins/pidgin-bot-sentry
parentx86 stable wrt bug #329149 (diff)
downloadgentoo-2-95f43c7e7fb69c33eb5e4c3b4fdd190f77bda7c0.tar.gz
gentoo-2-95f43c7e7fb69c33eb5e4c3b4fdd190f77bda7c0.tar.bz2
gentoo-2-95f43c7e7fb69c33eb5e4c3b4fdd190f77bda7c0.zip
Add pidgin-bot-sentry, a pidgin plugin to block spam.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/pidgin-bot-sentry')
-rw-r--r--x11-plugins/pidgin-bot-sentry/ChangeLog10
-rw-r--r--x11-plugins/pidgin-bot-sentry/metadata.xml15
-rw-r--r--x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild31
3 files changed, 56 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-bot-sentry/ChangeLog b/x11-plugins/pidgin-bot-sentry/ChangeLog
new file mode 100644
index 000000000000..01e84f3ec79f
--- /dev/null
+++ b/x11-plugins/pidgin-bot-sentry/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-plugins/pidgin-bot-sentry
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-bot-sentry/ChangeLog,v 1.1 2010/07/21 04:16:03 chutzpah Exp $
+
+*pidgin-bot-sentry-1.3.0 (21 Jul 2010)
+
+ 21 Jul 2010; Patrick McLean <chutzpah@gentoo.org>
+ +pidgin-bot-sentry-1.3.0.ebuild, +metadata.xml:
+ Add pidgin-bot-sentry, a pidgin plugin to block spam.
+
diff --git a/x11-plugins/pidgin-bot-sentry/metadata.xml b/x11-plugins/pidgin-bot-sentry/metadata.xml
new file mode 100644
index 000000000000..33a537d0d675
--- /dev/null
+++ b/x11-plugins/pidgin-bot-sentry/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+</maintainer>
+<longdescription lang="en">
+ Bot Sentry is a Pidgin (libpurple) plugin to prevent Instant Message (IM)
+ spam. It allows you to ignore IMs unless the sender is in your Buddy List,
+ the sender is in your Allow List, or the sender correctly answers a question
+ you have predefined.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild b/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild
new file mode 100644
index 000000000000..e99fdb4a270e
--- /dev/null
+++ b/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild,v 1.1 2010/07/21 04:16:03 chutzpah Exp $
+
+EAPI="3"
+
+inherit eutils multilib
+
+MY_P="${P#pidgin-}"
+DESCRIPTION="Bot Sentry is a Pidgin plugin to prevent Instant Message (IM) spam."
+HOMEPAGE="http://pidgin-bs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pidgin-bs/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin[gtk]
+ >=x11-libs/gtk+-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}