summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-12-09 07:41:45 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-12-09 07:41:45 +0000
commitae915be68e393b5e9fef010e54c4980b66df1581 (patch)
tree18172b4b4ce56ecd02d3fb4a6b8c635bf116fa3f /x11-plugins/pidgin-facebookchat
parentAdd patch to drop including .gnu.hash support on mips targets. (diff)
downloadgentoo-2-ae915be68e393b5e9fef010e54c4980b66df1581.tar.gz
gentoo-2-ae915be68e393b5e9fef010e54c4980b66df1581.tar.bz2
gentoo-2-ae915be68e393b5e9fef010e54c4980b66df1581.zip
Version bump, fixes 2 crashes, and the status message now updates properly
(Portage version: 2.2_rc17/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'x11-plugins/pidgin-facebookchat')
-rw-r--r--x11-plugins/pidgin-facebookchat/ChangeLog8
-rw-r--r--x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.43.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-facebookchat/ChangeLog b/x11-plugins/pidgin-facebookchat/ChangeLog
index c8c21cdf0788..4114a90178af 100644
--- a/x11-plugins/pidgin-facebookchat/ChangeLog
+++ b/x11-plugins/pidgin-facebookchat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/pidgin-facebookchat
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/ChangeLog,v 1.10 2008/12/03 08:56:42 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/ChangeLog,v 1.11 2008/12/09 07:41:45 voyageur Exp $
+
+*pidgin-facebookchat-1.43 (09 Dec 2008)
+
+ 09 Dec 2008; Bernard Cafarelli <voyageur@gentoo.org>
+ +pidgin-facebookchat-1.43.ebuild:
+ Version bump, fixes 2 crashes, and the status message now updates properly
03 Dec 2008; Bernard Cafarelli <voyageur@gentoo.org>
pidgin-facebookchat-1.41.ebuild:
diff --git a/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.43.ebuild b/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.43.ebuild
new file mode 100644
index 000000000000..364cfde06ed0
--- /dev/null
+++ b/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.43.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.43.ebuild,v 1.1 2008/12/09 07:41:45 voyageur Exp $
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Facebook chat plugin for libpurple"
+HOMEPAGE="http://code.google.com/p/pidgin-facebookchat/"
+
+SRC_URI="http://pidgin-facebookchat.googlecode.com/files/${PN}-source-${PV}.tar.bz2"
+LICENSE="GPL-3"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=net-im/pidgin-2.3.0"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ # Grabbed from makefile
+ FACEBOOK_SOURCES="libfacebook.c fb_blist.c fb_connection.c fb_info.c fb_managefriends.c fb_messages.c fb_notifications.c fb_search.c"
+ # Remove NO_ZLIB when it's working
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} `pkg-config --cflags purple` \
+ -DPURPLE_PLUGINS -DENABLE_NLS -DNO_ZLIB -shared -fPIC -DPIC \
+ ${FACEBOOK_SOURCES} -o libfacebook.so || die "compilation failed"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/purple-2
+ doexe libfacebook.so
+ for size in 16 22 48; do
+ insinto /usr/share/pixmaps/pidgin/protocols/${size}
+ newins facebook${size}.png facebook.png
+ done
+}