summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-07-17 01:31:38 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-07-17 01:31:38 +0000
commita5cea0f68de2134f9c7b125f1de6ef95943bfe1d (patch)
tree4947e6ec92cc12b5512346c345d3dab8cf433bea /x11-plugins/wmdate
parenterror check sed; use emake; modify Makefile to make parallel-friendly (Manife... (diff)
downloadgentoo-2-a5cea0f68de2134f9c7b125f1de6ef95943bfe1d.tar.gz
gentoo-2-a5cea0f68de2134f9c7b125f1de6ef95943bfe1d.tar.bz2
gentoo-2-a5cea0f68de2134f9c7b125f1de6ef95943bfe1d.zip
Initial import of x11-plugins/wmdate, version 0.7. Closes #54551
Diffstat (limited to 'x11-plugins/wmdate')
-rw-r--r--x11-plugins/wmdate/ChangeLog9
-rw-r--r--x11-plugins/wmdate/Manifest3
-rw-r--r--x11-plugins/wmdate/files/digest-wmdate-0.71
-rw-r--r--x11-plugins/wmdate/files/wmdate-ComplexProgramTargetNoMan.patch11
-rw-r--r--x11-plugins/wmdate/files/wmdate.desktop9
-rw-r--r--x11-plugins/wmdate/metadata.xml5
-rw-r--r--x11-plugins/wmdate/wmdate-0.7.ebuild41
7 files changed, 79 insertions, 0 deletions
diff --git a/x11-plugins/wmdate/ChangeLog b/x11-plugins/wmdate/ChangeLog
new file mode 100644
index 000000000000..ad5298c8d550
--- /dev/null
+++ b/x11-plugins/wmdate/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-plugins/wmdate
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdate/ChangeLog,v 1.1 2004/07/17 01:31:38 s4t4n Exp $
+
+*wmdate-0.7 (17 Jul 2004)
+
+ 17 Jul 2004; Michele Noberasci <s4t4n@gentoo.org> wmdate-0.7.ebuild:
+ Initial import. Thanks to Przemyslaw Maciag. Closes #54551.
+
diff --git a/x11-plugins/wmdate/Manifest b/x11-plugins/wmdate/Manifest
new file mode 100644
index 000000000000..265a8bdaa038
--- /dev/null
+++ b/x11-plugins/wmdate/Manifest
@@ -0,0 +1,3 @@
+MD5 7bd906463a7fb689f6c740b7a119a808 wmdate-0.7.ebuild 861
+MD5 cbce7d60a34c9e6e85e1ceca103ba8b0 files/wmdate.desktop 210
+MD5 3531a546777dce8d7d88b1a576413556 files/digest-wmdate-0.7 61
diff --git a/x11-plugins/wmdate/files/digest-wmdate-0.7 b/x11-plugins/wmdate/files/digest-wmdate-0.7
new file mode 100644
index 000000000000..7926b5da3052
--- /dev/null
+++ b/x11-plugins/wmdate/files/digest-wmdate-0.7
@@ -0,0 +1 @@
+MD5 967a20599124da13c876d12cfe08e3a5 wmdate-0.7.tar.gz 10645
diff --git a/x11-plugins/wmdate/files/wmdate-ComplexProgramTargetNoMan.patch b/x11-plugins/wmdate/files/wmdate-ComplexProgramTargetNoMan.patch
new file mode 100644
index 000000000000..3f24316f7d19
--- /dev/null
+++ b/x11-plugins/wmdate/files/wmdate-ComplexProgramTargetNoMan.patch
@@ -0,0 +1,11 @@
+--- wmdate-0.7./Imakefile~ Mon Nov 26 06:13:46 2001
++++ wmdate-0.7/Imakefile Mon Nov 26 06:13:46 2001
+@@ -132,7 +132,7 @@
+ XCOMM Create Makefile
+ XCOMM ---------------------------------------
+
+-ComplexProgramTarget(wmdate)
++ComplexProgramTargetNoMan(wmdate)
+
+ XCOMM - - - - - - - - - - - - - - - - - - - -
+ XCOMM e n d
diff --git a/x11-plugins/wmdate/files/wmdate.desktop b/x11-plugins/wmdate/files/wmdate.desktop
new file mode 100644
index 000000000000..6866e667cf64
--- /dev/null
+++ b/x11-plugins/wmdate/files/wmdate.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=WmDate
+Comment=Dockable date-display utility for X11
+Comment[pl]=Dokowalny wyświetlacz daty dla X11
+Exec=wmdate
+Type=Application
+Encoding=UTF-8
+Terminal=0
+Categories=Application;Calendar;
diff --git a/x11-plugins/wmdate/metadata.xml b/x11-plugins/wmdate/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmdate/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmdate/wmdate-0.7.ebuild b/x11-plugins/wmdate/wmdate-0.7.ebuild
new file mode 100644
index 000000000000..5341692b9a37
--- /dev/null
+++ b/x11-plugins/wmdate/wmdate-0.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdate/wmdate-0.7.ebuild,v 1.1 2004/07/17 01:31:38 s4t4n Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="yet another date-display dock application"
+SRC_URI="http://solfertje.student.utwente.nl/~dalroi/${PN}/files/${P}.tar.gz"
+HOMEPAGE="http://solfertje.student.utwente.nl/~dalroi/applications.php"
+
+DEPEND="virtual/x11
+ >=x11-libs/libdockapp-0.4.0-r1"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-ComplexProgramTargetNoMan.patch
+}
+
+src_compile() {
+ cd ${S}
+ PATH="$PATH:/usr/X11R6/bin"
+ xmkmf -a
+ emake CDEBUGFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+ einstall DESTDIR=${D} BINDIR=/usr/bin || DIE "make install failed"
+
+ dodoc README
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/${PN}.desktop
+}