summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-01-12 01:13:56 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-01-12 01:13:56 +0000
commit74e76b28cb8e53128afae28630ed5f09ca223418 (patch)
tree02c3441f1e0c49da24577ba81b5bd9aa29a48f71 /x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild
parentAdd libXpm to DEPEND (#204541), depend on =x11-libs/gtk+-1*, misc QA fixes. (diff)
downloadgentoo-2-74e76b28cb8e53128afae28630ed5f09ca223418.tar.gz
gentoo-2-74e76b28cb8e53128afae28630ed5f09ca223418.tar.bz2
gentoo-2-74e76b28cb8e53128afae28630ed5f09ca223418.zip
Add pkgconfig to DEPEND (#204543), misc QA fixes.
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild')
-rw-r--r--x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild29
1 files changed, 11 insertions, 18 deletions
diff --git a/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild b/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild
index 7fa912dd7c3c..2c5f69738e56 100644
--- a/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild
+++ b/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild,v 1.5 2006/11/18 22:35:43 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild,v 1.6 2008/01/12 01:13:56 coldwind Exp $
inherit eutils
IUSE=""
-DESCRIPTION="wmDrawer is a dock application (dockapp) which provides a drawer (retractable button bar) to launch applications"
+DESCRIPTION="dockapp which provides a drawer (retractable button bar) to launch applications"
SRC_URI="http://people.easter-eggs.org/~valos/wmdrawer/${P}.tar.gz"
HOMEPAGE="http://people.easter-eggs.org/~valos/wmdrawer/"
@@ -13,28 +13,21 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ppc ~sparc x86"
-DEPEND=" >=x11-libs/gtk+-2
- >=sys-apps/sed-4"
+RDEPEND=">=x11-libs/gtk+-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
-src_unpack ()
-{
+src_unpack () {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gtk+-2.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gtk+-2.patch
# Honour Gentoo CFLAGS
- sed -i -e "s|-O3|${CFLAGS}|" Makefile
+ sed -i -e "s|-O3|${CFLAGS}|" Makefile || die
}
-src_compile()
-{
- emake || die "make failed!"
-}
-
-src_install()
-{
+src_install() {
dobin wmdrawer
dodoc README TODO AUTHORS ChangeLog wmdrawerrc.example
- gzip -cd doc/wmdrawer.1x.gz > wmdrawer.1
doman wmdrawer.1
}