summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-07 16:24:05 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-07 16:24:05 +0000
commit629fe536cab92e2f3e2c895e227c0dac338d01d5 (patch)
tree9bb377ec5acecda19012d4cacd18e107c91e7803 /x11-plugins/wmgtemp
parentRemoved RDEPEND on ghostscript and left comment in pkg_postinst about (diff)
downloadgentoo-2-629fe536cab92e2f3e2c895e227c0dac338d01d5.tar.gz
gentoo-2-629fe536cab92e2f3e2c895e227c0dac338d01d5.tar.bz2
gentoo-2-629fe536cab92e2f3e2c895e227c0dac338d01d5.zip
New ebuild for wmgtemp. See bug #4888. Added optimization and doc
installation.
Diffstat (limited to 'x11-plugins/wmgtemp')
-rw-r--r--x11-plugins/wmgtemp/ChangeLog9
-rw-r--r--x11-plugins/wmgtemp/files/digest-wmgtemp-0.61
-rw-r--r--x11-plugins/wmgtemp/wmgtemp-0.6.ebuild40
3 files changed, 50 insertions, 0 deletions
diff --git a/x11-plugins/wmgtemp/ChangeLog b/x11-plugins/wmgtemp/ChangeLog
new file mode 100644
index 000000000000..490a7d35043a
--- /dev/null
+++ b/x11-plugins/wmgtemp/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-plugins/wmgtemp
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmgtemp/ChangeLog,v 1.1 2002/10/07 16:24:05 raker Exp $
+
+*wmgtemp-0.6 (07 Oct 2002)
+
+ 07 Oct 2002; Nick Hadaway <raker@gentoo.org> wmgtemp-0.6.ebuild,
+ files/digest-wmgtemp-0.6 :
+ New ebuild. See bug #4888. Added optimization and doc installation.
diff --git a/x11-plugins/wmgtemp/files/digest-wmgtemp-0.6 b/x11-plugins/wmgtemp/files/digest-wmgtemp-0.6
new file mode 100644
index 000000000000..b14d3016fc0d
--- /dev/null
+++ b/x11-plugins/wmgtemp/files/digest-wmgtemp-0.6
@@ -0,0 +1 @@
+MD5 63bacb693a7499773c8746aa8c0e6489 wmgtemp-0.6.tar.gz 18999
diff --git a/x11-plugins/wmgtemp/wmgtemp-0.6.ebuild b/x11-plugins/wmgtemp/wmgtemp-0.6.ebuild
new file mode 100644
index 000000000000..ae022e30bd46
--- /dev/null
+++ b/x11-plugins/wmgtemp/wmgtemp-0.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmgtemp/wmgtemp-0.6.ebuild,v 1.1 2002/10/07 16:24:05 raker Exp $
+
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+DESCRIPTION="CPU and SYS temperature dockapp"
+HOMEPAGE="http://www.fluxcode.net"
+SRC_URI="http://www.fluxcode.net/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+DEPEND="sys-apps/lm_sensors"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ # Set compile optimizations
+ cd ${S}/src
+ cp Makefile Makefile.orig
+ sed -e "s:-Wall -g:\$(CFLAGS):" \
+ Makefile.orig > Makefile
+
+ emake || die "parallel make failed"
+
+}
+
+src_install() {
+
+ cd ${S}
+ dodoc BUGS CREDITS INSTALL README TODO
+
+ cd ${S}/src
+ dobin wmgtemp
+
+}