summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2009-01-15 11:32:30 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2009-01-15 11:32:30 +0000
commit0cf24738dbe9e59b22ad04ebcd5940b3fbd6256c (patch)
tree6bd54fb4a4dd6494bca719c8c673919c72400ee9 /x11-plugins/wmmsg
parentFixed description (diff)
downloadgentoo-2-0cf24738dbe9e59b22ad04ebcd5940b3fbd6256c.tar.gz
gentoo-2-0cf24738dbe9e59b22ad04ebcd5940b3fbd6256c.tar.bz2
gentoo-2-0cf24738dbe9e59b22ad04ebcd5940b3fbd6256c.zip
Revision bump, with patch to fix monitor_desktops feature. Closes bug #253498.
(Portage version: 2.1.6.4/cvs/Linux 2.6.24-tuxonice-r9 i686)
Diffstat (limited to 'x11-plugins/wmmsg')
-rw-r--r--x11-plugins/wmmsg/ChangeLog8
-rw-r--r--x11-plugins/wmmsg/files/wmmsg-1.0.1-alt-desktop.patch11
-rw-r--r--x11-plugins/wmmsg/wmmsg-1.0.1-r1.ebuild36
3 files changed, 54 insertions, 1 deletions
diff --git a/x11-plugins/wmmsg/ChangeLog b/x11-plugins/wmmsg/ChangeLog
index cc6d03dd3912..a096543c544b 100644
--- a/x11-plugins/wmmsg/ChangeLog
+++ b/x11-plugins/wmmsg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmmsg
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmsg/ChangeLog,v 1.16 2008/03/23 13:27:54 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmsg/ChangeLog,v 1.17 2009/01/15 11:32:30 s4t4n Exp $
+
+*wmmsg-1.0.1-r1 (15 Jan 2009)
+
+ 15 Jan 2009; Michele Noberasco <s4t4n@gentoo.org>
+ +files/wmmsg-1.0.1-alt-desktop.patch, +wmmsg-1.0.1-r1.ebuild:
+ Revision bump, with patch to fix monitor_desktops feature. Closes bug #253498.
23 Mar 2008; nixnut <nixnut@gentoo.org> wmmsg-1.0.1.ebuild:
Stable on ppc wrt bug 214344
diff --git a/x11-plugins/wmmsg/files/wmmsg-1.0.1-alt-desktop.patch b/x11-plugins/wmmsg/files/wmmsg-1.0.1-alt-desktop.patch
new file mode 100644
index 000000000000..5a7135d7cc30
--- /dev/null
+++ b/x11-plugins/wmmsg/files/wmmsg-1.0.1-alt-desktop.patch
@@ -0,0 +1,11 @@
+--- wmmsg-1.0.1/src/wmmsg/wmmsg.c.vns 2003-02-04 06:40:12 +0300
++++ wmmsg-1.0.1/src/wmmsg/wmmsg.c 2006-03-26 21:42:45 +0400
+@@ -144,7 +144,7 @@
+ WMMSG_MASK_WIDTH, WMMSG_MASK_HEIGHT);
+ openXwindow (argc, argv, wmmsg_xpm, global_wmmsg_mask_bits,
+ WMMSG_MASK_WIDTH, WMMSG_MASK_HEIGHT);
+- global_win_workspace = XInternAtom(display, "_WIN_WORKSPACE", 0);
++ global_win_workspace = XInternAtom(display, "_NET_CURRENT_DESKTOP", 0);
+
+ //add clickable regions
+ for(i = 0; i < MESSAGES_PER_SCREEN; i++)
diff --git a/x11-plugins/wmmsg/wmmsg-1.0.1-r1.ebuild b/x11-plugins/wmmsg/wmmsg-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..56efa8520887
--- /dev/null
+++ b/x11-plugins/wmmsg/wmmsg-1.0.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmsg/wmmsg-1.0.1-r1.ebuild,v 1.1 2009/01/15 11:32:30 s4t4n Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="a dockapp that informs events, such as incoming chat messages, by displaying icons and times"
+HOMEPAGE="http://swapspace.net/~matt/wmmsg"
+SRC_URI="http://swapspace.net/~matt/wmmsg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2
+ media-libs/imlib2
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-libs/libXt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-use_gtk2.patch
+ epatch "${FILESDIR}"/${P}-alt-desktop.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README wmmsgrc
+}