summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2005-07-22 08:30:37 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2005-07-22 08:30:37 +0000
commit8dfa8c52934a6f9866581b873d2b73f97e40ae8a (patch)
tree644706c299f27d8920e00e77fe02a7d1c72895f6 /x11-plugins/wmpower/wmpower-0.4.2.ebuild
parentStable on x86 (diff)
downloadgentoo-2-8dfa8c52934a6f9866581b873d2b73f97e40ae8a.tar.gz
gentoo-2-8dfa8c52934a6f9866581b873d2b73f97e40ae8a.tar.bz2
gentoo-2-8dfa8c52934a6f9866581b873d2b73f97e40ae8a.zip
Version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-plugins/wmpower/wmpower-0.4.2.ebuild')
-rw-r--r--x11-plugins/wmpower/wmpower-0.4.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-plugins/wmpower/wmpower-0.4.2.ebuild b/x11-plugins/wmpower/wmpower-0.4.2.ebuild
new file mode 100644
index 000000000000..3b3e118dbb12
--- /dev/null
+++ b/x11-plugins/wmpower/wmpower-0.4.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpower/wmpower-0.4.2.ebuild,v 1.1 2005/07/22 08:30:37 s4t4n Exp $
+
+IUSE=""
+
+DESCRIPTION="WMaker DockApp to get (and set) power management status for laptops. Supports APM and ACPI kernels. Supports CPUfreq. Also has special support for Toshiba, Dell and Compal hardware."
+HOMEPAGE="http://wmpower.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wmpower/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND="virtual/x11"
+
+src_compile()
+{
+ # override wmpower self-calculated cflags
+ econf MY_CFLAGS="${CFLAGS}" || die "Configuration failed"
+ emake prefix="/usr/" || die "Compilation failed"
+}
+
+src_install()
+{
+ einstall || die "Installation failed"
+ dodoc AUTHORS BUGS COPYING ChangeLog LEGGIMI NEWS README README.compal THANKS TODO
+}