summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-05-11 09:43:13 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-05-11 09:43:13 +0000
commit3aa1aa7183d77ec52bd79d5fad1f1b919e547acc (patch)
treeefde71f97b0efcf685d2a3c0f623decc999cbd76 /x11-plugins/wmtime
parentsci-chemistry/ccpn: Bump to latest python fixes (diff)
downloadgentoo-2-3aa1aa7183d77ec52bd79d5fad1f1b919e547acc.tar.gz
gentoo-2-3aa1aa7183d77ec52bd79d5fad1f1b919e547acc.tar.bz2
gentoo-2-3aa1aa7183d77ec52bd79d5fad1f1b919e547acc.zip
Version bump, EAPI 4 and ebuild cleanups. Also switch to mirror://debian/, bug #415263
(Portage version: 2.2.0_alpha103/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/wmtime')
-rw-r--r--x11-plugins/wmtime/ChangeLog11
-rw-r--r--x11-plugins/wmtime/wmtime-1.0_beta2_p10.ebuild61
2 files changed, 70 insertions, 2 deletions
diff --git a/x11-plugins/wmtime/ChangeLog b/x11-plugins/wmtime/ChangeLog
index 2dc47ea87a94..a88f8330a576 100644
--- a/x11-plugins/wmtime/ChangeLog
+++ b/x11-plugins/wmtime/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/wmtime
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtime/ChangeLog,v 1.3 2010/09/03 13:34:09 s4t4n Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtime/ChangeLog,v 1.4 2012/05/11 09:43:13 voyageur Exp $
+
+*wmtime-1.0_beta2_p10 (11 May 2012)
+
+ 11 May 2012; Bernard Cafarelli <voyageur@gentoo.org>
+ +wmtime-1.0_beta2_p10.ebuild:
+ Version bump, EAPI 4 and ebuild cleanups. Also switch to mirror://debian/,
+ bug #415263
03 Sep 2010; Michele Noberasco <s4t4n@gentoo.org> wmtime-1.0_beta2_p9.ebuild:
Honour Gentoo LDFLAGS, bug #335799.
diff --git a/x11-plugins/wmtime/wmtime-1.0_beta2_p10.ebuild b/x11-plugins/wmtime/wmtime-1.0_beta2_p10.ebuild
new file mode 100644
index 000000000000..3e15fa154636
--- /dev/null
+++ b/x11-plugins/wmtime/wmtime-1.0_beta2_p10.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtime/wmtime-1.0_beta2_p10.ebuild,v 1.1 2012/05/11 09:43:13 voyageur Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs versionator
+
+MY_PV="$(get_version_component_range 1-2)"
+MY_PL="$(get_version_component_range 3)"
+MY_PL="${MY_PL/beta/b}"
+MY_PV="${MY_PV}${MY_PL}"
+MY_PL="$(get_version_component_range 4)"
+MY_PL="${MY_PL/p/}"
+
+IUSE=""
+
+DESCRIPTION="applet which displays the date and time in a dockable tile"
+SRC_URI="mirror://debian/pool/main/w/wmtime/wmtime_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/w/wmtime/wmtime_${MY_PV}-${MY_PL}.diff.gz"
+HOMEPAGE="http://packages.qa.debian.org/w/wmtime.html"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${PN}-${MY_PV}.orig/${PN}
+
+src_prepare() {
+ cd "${WORKDIR}"
+
+ # apply debian patch
+ epatch ${PN}_${MY_PV}-${MY_PL}.diff
+
+ # honour Gentoo LDFLAGS, bug #335799
+ sed -i "s/-o wmtime/\$(LDFLAGS) -o wmtime/" "${S}/Makefile"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install () {
+ dobin wmtime
+ doman wmtime.1
+
+ cd ..
+ dodoc BUGS CHANGES HINTS README TODO
+
+ # install sample config file, too
+ dodoc debian/wmtimerc
+}