summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-09-19 01:51:40 +0000
committerDaniel Goller <morfic@gentoo.org>2004-09-19 01:51:40 +0000
commitee1b32766789abcc042a5aa53cdbe7e7c28e47e4 (patch)
tree7511c21687b57b1a9fcefa1d1a7eb938361c7121 /x11-plugins/wmtz/wmtz-0.7.ebuild
parentPackage "app-sci/staden-emboss" was removed from Portage. (diff)
downloadgentoo-2-ee1b32766789abcc042a5aa53cdbe7e7c28e47e4.tar.gz
gentoo-2-ee1b32766789abcc042a5aa53cdbe7e7c28e47e4.tar.bz2
gentoo-2-ee1b32766789abcc042a5aa53cdbe7e7c28e47e4.zip
closing bug #64556, thanks Magnade
Diffstat (limited to 'x11-plugins/wmtz/wmtz-0.7.ebuild')
-rw-r--r--x11-plugins/wmtz/wmtz-0.7.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/x11-plugins/wmtz/wmtz-0.7.ebuild b/x11-plugins/wmtz/wmtz-0.7.ebuild
index 6884b888266c..1e0d7b22068a 100644
--- a/x11-plugins/wmtz/wmtz-0.7.ebuild
+++ b/x11-plugins/wmtz/wmtz-0.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtz/wmtz-0.7.ebuild,v 1.9 2004/09/02 18:22:40 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtz/wmtz-0.7.ebuild,v 1.10 2004/09/19 01:51:40 morfic Exp $
-inherit eutils
+inherit eutils gcc
IUSE=""
DESCRIPTION="dockapp that shows the time in multiple timezones."
@@ -15,6 +15,17 @@ KEYWORDS="x86 amd64 ppc"
DEPEND="virtual/x11"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ #apply both patches to compile with gcc-3.4 closing bug #
+ if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]
+ then
+ epatch ${FILESDIR}/wmtz-0.7-gcc34.patch
+ fi
+}
+
src_compile() {
cd ${S}/wmtz
epatch ${FILESDIR}/wmtz.c.patch