summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-08-09 15:54:10 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-08-09 15:54:10 +0000
commit00c695dec47e36291fe66642aa29a499d1996a0b (patch)
tree0eca13485bc24a27310174e3139ad31c1eea4b1f /x11-plugins
parentRestrict tests on 3.6 platform as it is unfinished. Wrt bug#430620. (diff)
downloadgentoo-2-00c695dec47e36291fe66642aa29a499d1996a0b.tar.gz
gentoo-2-00c695dec47e36291fe66642aa29a499d1996a0b.tar.bz2
gentoo-2-00c695dec47e36291fe66642aa29a499d1996a0b.zip
version bump
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-opensteamworks/ChangeLog8
-rw-r--r--x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p34.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-opensteamworks/ChangeLog b/x11-plugins/pidgin-opensteamworks/ChangeLog
index c61834d72183..9ee85e93b5fd 100644
--- a/x11-plugins/pidgin-opensteamworks/ChangeLog
+++ b/x11-plugins/pidgin-opensteamworks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/pidgin-opensteamworks
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/ChangeLog,v 1.6 2012/07/09 17:33:14 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/ChangeLog,v 1.7 2012/08/09 15:54:10 hasufell Exp $
+
+*pidgin-opensteamworks-1.0_p34 (09 Aug 2012)
+
+ 09 Aug 2012; Julian Ospald <hasufell@gentoo.org>
+ +pidgin-opensteamworks-1.0_p34.ebuild:
+ version bump
09 Jul 2012; Johannes Huber <johu@gentoo.org>
pidgin-opensteamworks-1.0_p32.ebuild:
diff --git a/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p34.ebuild b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p34.ebuild
new file mode 100644
index 000000000000..ca447687ae8c
--- /dev/null
+++ b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p34.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p34.ebuild,v 1.1 2012/08/09 15:54:10 hasufell Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Steam protocol plugin for pidgin"
+HOMEPAGE="http://code.google.com/p/pidgin-opensteamworks/"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz
+ http://pidgin-opensteamworks.googlecode.com/files/icons.zip
+ -> ${PN}-icons.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ net-im/pidgin"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ virtual/pkgconfig"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ # see http://code.google.com/p/pidgin-opensteamworks/issues/detail?id=31
+ cp "${FILESDIR}"/${PN}-1.0_p32-Makefile "${S}"/Makefile || die
+}
+
+src_install() {
+ default
+ insinto /usr/share/pixmaps/pidgin/protocols
+ doins -r "${WORKDIR}"/{16,48}
+}